Formule excel avec chiffre négatif [Résolu/Fermé]

Signaler
Messages postés
10
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
2 mai 2017
-
Messages postés
10
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
2 mai 2017
-
Bonjour,

D'abord merci à ceux qui me répondront pour cette question.

J'aurais besoin d'une formule excel qui donnerait le resultat suivant :

Ex

A1 (ex:100) + B1 (ex:200) = C1(300)

A1 (ex:100) + B1 (ex: -200) = C1(100)

Dans cet exemple, si le chiffre en B1 est négatif, alors il ne s'ajoute pas.
J'ignore si on peut faire cela.

Merci à tous et bonne journée.
A voir également:

3 réponses

Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 498
Re,

mais 100-200=-100 ce qui est normal
tu peux créer un format personnalisé qui affichera 100 mais dans tout mode de calcul Excel n'oubliera pas qu'il s'agit d'une valeur négative

teste le format personnalisé pour tes cellules en colonne C
Format de Cellule/onglet Nombre/Personnalisée
et colle ce format
0;[Noir]0

ou par formule à tester
=STXT(TEXTE(A1+B1;"0");TROUVE("-";TEXTE(A1+B1;"0");1)+1;10)*1
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
10
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
2 mai 2017

Merci beaucoup. Cependant la formule ne pas celle dont j'ai besoin, mais me convient pour un autre calcul. C'est cool.
Messages postés
8435
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
20 février 2021
1 610
Bonjour,

Si tu veux ignorer les nombres négatifs, alors utilises :
=A1+MAX(B1;0)
Messages postés
17301
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 janvier 2021
4 498
Salut Patrice,

Ah oui, bien vu
Messages postés
10
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
2 mai 2017

La formule fonctionne pour mes besoins. Merci beaucoup.
Messages postés
2333
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
22 février 2021
1 020
Bonjour
autre solution
=SI(B1<0;A1;A1+B1)
Messages postés
10
Date d'inscription
vendredi 28 avril 2017
Statut
Membre
Dernière intervention
2 mai 2017

Merci, elle convient également. :-)