Incrémentation de formule avec saut de cellules [Résolu/Fermé]

Signaler
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019
-
Bonjour,
Ma question a certainement déjà été posée mais je ne parviens pas à trouver une réponse.
Je dispose d'un tableau de données horaires avec 35066 lignes et 14 colonnes, et je voudrais réaliser la moyenne journalière pour chaque colonne en faisant un saut de 24 lignes ,comment pourrais-je dérouler la formule initiale exp: =moyenne(B2:B25) pour passer directement à =moyenne(B25:B50) pour la cellule suivante et non pas à =moyenne(B4:B26)...
J'ai essayée plusieurs manip avec la fonction DECALER mais je ne parviens toujours pas a trouver la bonne.

Si ma demande n'est pas très claire, voici un modèle : https://www.cjoint.com/c/GEqq5tSglrD

Merci d'avance pour vos réponses

5 réponses

Messages postés
23375
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 juin 2020
6 221
Bonjour,

elle était presque bonne ta formule, il manque juste un $. En B2 :
=SIERREUR(MOYENNE(DECALER(Donnees!B$2;24*(LIGNE()-2);;24;));"")

eric

En essayant continuellement, on finit par réussir. 
Donc plus ça rate, plus on a de chances que ça marche.(les Shadoks)
En plus du merci (si si, ça se fait !!!), penser à mettre en résolu. Merci
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64700 internautes nous ont dit merci ce mois-ci

Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Bonsoir,

tu peux faire directement et sur n'importe quelle feuille avec ce genre de formule
si ta première formule est sur la ligne2 tu insères dans la formule la syntaxe LIGNE() qui te donnera l'index de la ligne, soit 2-1 ce qui te donnera 1 si ta première formule est sur la ligne 10 la syntaxe sera LIGNE()-9
incrémente la formule vers le bas
=MOYENNE(INDIRECT("B"&(LIGNE()-1)*25-24&":B"&(LIGNE()-1)*25))

de même si tu dois incrémenter comme sur ton fichier la formule vers la droite on utilisera de la même manière la syntaxe COLONNE() et pour la première formule colonne P
=MOYENNE(INDIRECT("B"&(COLONNE()-15)*25-24&":B"&(COLONNE()-15)*25))

Messages postés
17133
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
3 juillet 2020
4 114
Salut Eriiic,
Ah oui Joli, bien vu
Bonne nuit
A+
Mike-31

Je suis responsable de ce que je dis, pas de ce que tu comprends...
Messages postés
23375
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 juin 2020
6 221
Dommage que je ne l'ai vu qu'après avoir construit la mienne ;-)
Bonne nuit également
Messages postés
1658
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
22 juin 2020
437
Cool, je connaissais pas ces fonctions ;)
Messages postés
1658
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
22 juin 2020
437
Salut,

Tu peux composer des formules avec la fonction INDIRECT(référence cellule). Dans ton cas, tes données sont dans la colonne B. Il faut que tu crée en D2 une case avec
1
en E2
=MOYENNE(INDIRECT("B"&D2*25-24&":B"&D2*25))
. En D3
=D2+1
et en étendant les formules, tu auras les moyennes des cases 1 à 25, 26 à 50 etc... Le & dans la formule permet de concaténer une chaîne de caractère. Si tes données commencent à B2, il faudra ajouter 1 partout.

Trust me and keep calm, I'm an engineer !
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

Salut ,
Merci pour votre réponse,
j'ai galéré un peu pour comprendre mais c'est bon mon problème est résolu grâce a vous, j'ai juste une petite question ,si je veux faire le calcul dans une nouvelle feuille, est-ce possible ? j'ai essayée la formule suivante: =MOYENNE(INDIRECT("Feuil1!B"&Feuil1!$D2*25-24&":Feuil1!B"&Feuil1!$D2*25)) , mais cela renvoie l'erreur #REF ! ???
Messages postés
1658
Date d'inscription
lundi 24 janvier 2011
Statut
Membre
Dernière intervention
22 juin 2020
437
INDIRECT("Feuil1!B"&Feuil1!$D2*25-24&":B"&Feuil1!$D2*25)
par exemple avec Feuil1 le nom de la feuille correspondante (un feuille en trop)
Messages postés
61
Date d'inscription
mardi 2 avril 2013
Statut
Membre
Dernière intervention
15 octobre 2019

c'est vraiment génial !! un grand Merci à vous tous ;-)