Recherche SOMMEPROD à multicritères [Fermé]

Signaler
Messages postés
3
Date d'inscription
lundi 27 février 2017
Statut
Membre
Dernière intervention
10 mars 2017
-
Messages postés
25988
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 avril 2021
-
Bonjour,

Je recherche comment faire une recherche d'information selon plusieurs critères.

Donc j'ai 4 feuilles différentes nommées Albert, Antoine, Janne et Sommaire.

Dans chaque feuille correspondant à des noms de personne, j’ai la collonne A qui correspond à l’heure d’entrée de l’employé, la colonne B à l’heure de fin, la colonne C correspond au code utilisé (P=pause, D=diner et A=absence), la colonne D est le temps travailler et j’ai la colonne E qui correspond à la semaine de l’année.

On travaille généralement sur une projet 2 semaines à l’avance donc si je suis dans la semaine 1 je peux travailler sur des projets de la semaine 2, 3 ou 4. Dans la colonne colonne E on indique la semaine du projet et non pas la semaine actuelle.

Dans la feuille Sommaire, J’ai la colonne A dont chaque cellule correspond à une semaine de l’année. Dans la colonne B, à côté de chaque semaine, je veux trouver la somme des absences par semaine.

Ex. : dans la cellule A13 il y est inscrit « 13 » (# de la semaine). Dans la cellule B13, je veux faire un SOMMEPROD qui va chercher dans la colonne « E » de chaque autre feuille pour y trouver la même valeur que A13 et faire la somme des valeurs de la colonne « D », mais seulement celle où ce serait écrit le code « A » dans la cellule à côté dans la colonne « C ».

Merci d’avance pour l’aide!


A voir également:

2 réponses

Messages postés
13004
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
25 avril 2021
2 179
Bonjour

Si j'ai bien compris :
=SOMMEPROD((Albert!C:C="A")*(Albert!E:E=A13)*(Albert!D:D))+SOMMEPROD((Antoine!C:C="A")*(Antoine!E:E=A13)*(Antoine!D:D))+SOMMEPROD((Janne !C:C="A")*(Janne !E:E=A13)*(Janne !D:D))

Cdlmnt
Via
Messages postés
25988
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 avril 2021
5 885
Bonjour


=SOMMEPROD((feuil1!E1:E100=A13)*(feuil1!C1:C100="A")*(Feuil1!D1:D100))+ idem pour feuil2 + idfem pour feuil3 etc...

crdlmnt