Héberger site wordpress sur OVH [Résolu/Fermé]

Signaler
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019
-
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019
-
Bonjour,

J'ai créé un site via wordpress en local, mais lorsque je l'importe sur OVH via Filezilla, une erreur apparaît lorsque je veux me connecter à mon site : "erreur lors de la connexion à la base de données". J'ai donc tout supprimé, réinstallé uniquement wordpress proprement, et retéléchargé mon site sur ma base de données sur OVH. Mais j'ai toujours la même erreur...

Quelqu'un aurait-il une idée de comment résoudre ça ?

D'avance merci, et bonne soirée.

1 réponse

Messages postés
5815
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
10 août 2020
1 079
Bonjour
est ce que tu as modifié le fichier wp-config.php ( a la racine du site) pour mettre les identifiants de connexion d'ovh ?
tu devras aussi peut être modifier quelques lignes dans la base de donnée pour que l'adresse de ton site soit la bonne
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 57358 internautes nous ont dit merci ce mois-ci

Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019

Bon du coup j'ai regardé un tutoriel pour faire tout ça proprement, donc j'ai entre autre modifié le fichier wp-config.php. Je peux accédé à monsite.fr mais pas à mon monsite.fr/autrepage ... Il recherche le local host, comment modifier celà ? Pareil, impossible d'accéder à monsite.fr/wp-admin. Comment dois-je procéder ?
Messages postés
5815
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
10 août 2020
1 079 >
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019

efface d'abord le fichier htaccess (il sera généré automatiquement par wordpress) dès que tu iras sur ton site,

ensuite va dans ta base de donnée et ouvre la table wp_options, dans les deux premières lignes site url et home, regarde si tu as des adresses du genre localhost/monsite,
si c'est le cas, double-clique sur la première adresse et mets la bonne adresse (sans slash / à la fin), valide en cliquant sur un espace vide de la page puis fais la même chose pour la seconde adresse puis va vérifier si ton site fonctionne
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019
>
Messages postés
5815
Date d'inscription
mercredi 30 octobre 2013
Statut
Membre
Dernière intervention
10 août 2020

J'ai effacé le fichier htaccess, puis modifié les deux premières lignes dans la table wp_options, mais toujours pareil... :(

EDIT : je suis stupide, ça a marché merci beaucoup ! Je n'avais pas réessayé d'accéder à WP, et là ça marche ! Merci encore ! :)
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019

Bon j'ai accès à WP enfin, mais j'ai ENCORE un problème. ^^' Tout marche bien, mais lorsque je visite mon site ( qu'on appellera encore monsite.fr pour éviter la pub ), lorsque je veux accéder à la page Bio par exemple, j'ai droit à une erreur 404 not found. Comment dois-je faire ? J'ai modifié dans WP dans le menu "menus" justement les urls, et j'ai vérifié les url des pages, et tout à l'air bon pourtant... Et l'erreur 404 persiste. ^^'
Messages postés
54
Date d'inscription
vendredi 19 août 2016
Statut
Membre
Dernière intervention
17 mai 2019

C'est tout bon j'ai trouvé ma réponse ici pour ceux que ça intéresse : https://forums.commentcamarche.net/forum/affich-27346641-erreur-404-page-introuvable-wordpress ! Bonne soirée à vous et merci encore de l'aide !