Recherche avancée

Résolu/Fermé
Signaler
Messages postés
435
Date d'inscription
mardi 14 mai 2013
Statut
Membre
Dernière intervention
24 mars 2021
-
Messages postés
435
Date d'inscription
mardi 14 mai 2013
Statut
Membre
Dernière intervention
24 mars 2021
-
Bonjour,

Après plusieurs tentatives, je fais appel à vous pour trouver la formule magique que je cherche.
Je vous joins un classeur exemple.

https://www.cjoint.com/c/GBpswG1yJH3

Dans ce classeur, j'ai une plage A2:C10 avec des numéros qui peuvent être en doublons. J'ai ensuite une plage A1:C1 où je peux inscrire un X.

En dessous, j'ai la liste des numéros uniques. À côté, j'aimerais qu'un X s'inscrive si le numéro se trouve dans la plage A2:C10 ET qu'il y a un x dans la plage A1:C1 au-dessus de la colonne où il se trouve.

Il faut considérer que dans mon fichier original j'ai beaucoup plus que 3 colonnes et 9 lignes.

Merci d'avance! :)

1 réponse

Messages postés
26307
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
2 décembre 2021
6 131
Bonsoir
essayez ça en B19, à adapter:

=SI(SOMMEPROD(($A$2:$Z$10=$A19)*($A$1:$Z$1="X"))=0;"";"X")

vous renverra X si au moins une colonne qui contient la valeur de A19 a un X en ligne 1

crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
435
Date d'inscription
mardi 14 mai 2013
Statut
Membre
Dernière intervention
24 mars 2021
25
Je me cassais beaucoup trop la tête! Je ne sais pas pourquoi je n'y suis pas arrivée! Merci beaucoup! :)