Rechercher Valeur dans une colonne selon deux critères [Résolu/Fermé]

Signaler
Messages postés
106
Date d'inscription
dimanche 10 novembre 2013
Statut
Membre
Dernière intervention
8 septembre 2020
-
Messages postés
17295
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 octobre 2020
-
Bonjour,

J'ai un peu de mal à expliquer ce que je recherche.
Je vous envoie une photo de mon tableau. Je pense vous comprendrez mieux.

Cordialement,



2 réponses

Messages postés
17295
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 octobre 2020
4 313
Bonsoir,

il aurait été préférable d'avoir un bout de fichier qu'une capture écran, mais regarde comme cela

=SOMMEPROD(($A$2:$A$20=$L$1)*($B$2:$B$20=$M$1)*($C$2:$C$20))

si tu n'as qu'une formule tu peux travailler en relatif
=SOMMEPROD((A2:A20=L1)*(B2:B20=M1)*(C2:C20))

ou avec des plages nommées
=SOMMEPROD((Dat=L1)*(Nom=M1)*(Text))

tu peux également utiliser cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))

A+
Mike-31

Pas savoir n'est pas un échec, l'échec est le refus d'apprendre.
Messages postés
106
Date d'inscription
dimanche 10 novembre 2013
Statut
Membre
Dernière intervention
8 septembre 2020

Malheureusement j'ai une erreur #valeur! sur votre formule SOMMEPROD
Voici le tableau ci-joint:
http://www.cjoint.com/c/GBos1dAarKc
Messages postés
17295
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
27 octobre 2020
4 313
Re,

utilise cette formule matricielle qu'il faudra confirmer en cliquant en même temps sur les trois touches Ctrl, Shift et Entrée et si tu fais bien la formule se placera entre ce type d'accolade {}
=INDEX(C2:C12;EQUIV(L1&M1;A2:A12&B2:B12;0))