Extraire une partie de texte d'une cellule [Résolu/Fermé]

Signaler
-
 Teka78 -
J'ai parcouru un peu votre forum mais je n'ai pas trouvé de réponse à ma question que voici.

J'ai une cellule A1 dans laquelle il y a (par ex) "EBP Liasse Fiscale Classic en ligne - abonnement annuel" ou "EBP Liasse Fiscale Classic en ligne - abonnement mensuel".
J'aimerai trouver une formule qui me permette dans une cellule B1, d'extraire le mot soit "mensuel" soit "annuel". Le problème étant que le mot "annuel" ou "mensuel" peut aussi bien être en fin de phrase qu'en milieu ou autre sans aucune logique particulière...

Quelqu'un aurait il une idée qui pourrait m'aider? sachant que je ne peux donc pas utiliser une formule permettant d'extraire à partir d'un certain nombre de caractère, ni à partir d'un caractère spécifique,...

merci a vous

4 réponses

Messages postés
1868
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
15 janvier 2021
54
Teka78, Bonjour.

Essayez d'utiliser cette formule:

=SI(ESTNUM(TROUVE("ANNUEL";A1;1));"ANNUEL";SI(ESTNUM(TROUVE("MENSUEL";A1;1));"MENSUEL";"----"))


Il était ce que vous vouliez?
J'espère avoir aidé.

Cordialement.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Merci beaucoup pour la proposition mais cela ne fonctionne pas pour mon cas. la formule me ressort toujours le même résultat quelque soit le texte dans la cellule A1.
Messages postés
2427
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
19 janvier 2021
920
Bonjour,
Essayez:
=SI(ESTNUM(CHERCHE("mensuel";A2));"mensuel";SI(ESTNUM(CHERCHE("annuel";A2));"annuel";""))
Ou remplacez Trouve par Cherche dans la formule de Mazzaropi, il n'y aura plus de distinction entre Majuscules et minuscules.
Youpii...Merci beaucoup ca fonctionne parfaitement. cela va me permettre de gagner beaucoup de temps