Afficher un résultat automatiquement + autre fonction

[Résolu/Fermé]
Signaler
-
Messages postés
3
Date d'inscription
lundi 2 janvier 2017
Statut
Membre
Dernière intervention
3 janvier 2017
-
Bonjour,

J'ai cherché un peu partout mais n'ai pas trouvé de solution à mon problème:

J'ai fais un tableau Excel avec des résultats à indiqué via une liste (OK; NOK),
et j'ai fais en sorte d'avoir un résultat final qui affiche OK si la totalité des step sont validé ou NOK si une seul étape a échoué, via cette fonction : =SI(NB.SI(A2:A15;"NOK")=0;"OK";"NOK")

Le problème est que de cette façon, la valeur dans ma case "résultat" est toujours sur OK, même lorsque les champs "A2:A15" ne sont pas remplis.

J'aimerais avoir donc une 3eme possibilité, si aucune valeur = "NA", si échec = "NOK", si validé = "OK".

Est-ce que ça vous semble possible ?

merci d'avance pour le coup de main :-)

2 réponses


Bonjour Dgomez,
Essaye avec : =SI(NB.SI(A2:A15;"NOK")>0;"NOK";"OK")
Cordialement.  :)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
lundi 2 janvier 2017
Statut
Membre
Dernière intervention
3 janvier 2017

Hélas non, même résultat que pour ma fonction, si aucune valeur n'est indiqué mon résultat reste sur "OK" :'(
Utilisateur anonyme >
Messages postés
3
Date d'inscription
lundi 2 janvier 2017
Statut
Membre
Dernière intervention
3 janvier 2017

 
Je viens de vérifier en mettant en A2:A15 des OK, des NOK ou rien.
Ma formule retourne NOK s'il y a au moins un NOK ; sinon, s'il y a
seulement des vides ou OK et aucun NOK, elle retourne OK.

Si aucune valeur n'est indiquée, ça retourne effectivement OK ;
si tu veux une cellule vide à la place :

=SI(NBVAL(A2:A15)=0;"";SI(NB.SI(A2:A15;"NOK")>0;"NOK";"OK"))
 
Messages postés
3
Date d'inscription
lundi 2 janvier 2017
Statut
Membre
Dernière intervention
3 janvier 2017

Justement, le problème est que je ne veux pas qu'il affiche "OK" si les champs sont vide.

J'aimerais avoir un troisième état, ou ne rien n'avoir d'indiquer si les champs ne sont pas rempli
 
Oui, j'ai bien compris ; c'est pourquoi j'ai écris :

«
si tu veux une cellule vide à la place :
=SI(NBVAL(A2:A15)=0;"";SI(NB.SI(A2:A15;"NOK")>0;"NOK";"OK"))
»

Donc avec cette formule, si toutes les cellules de A2:A15 sont vides,
la formule retourne "" => cellule vide au lieu de « OK ».

Pour un 3ème état, tu peux mettre :
=SI(NBVAL(A2:A15)=0;"Plage vide";SI(NB.SI(A2:A15;"NOK")>0;"NOK";"OK"))

Tu peux bien sûr mettre le texte de ton choix à la place de « Plage vide ».
 
Messages postés
3
Date d'inscription
lundi 2 janvier 2017
Statut
Membre
Dernière intervention
3 janvier 2017
> Utilisateur anonyme
Ah oui effectivement je n'avais pas vu la fin de ton message.
ça fonctionne nickel comme ça !

Un grand merci à toi :-)