Comparer des valeurs texte non vides sur une ligne

Résolu/Fermé
mich2p1
Messages postés
5
Date d'inscription
samedi 3 décembre 2011
Statut
Membre
Dernière intervention
16 décembre 2016
- 16 déc. 2016 à 10:36
mich2p1
Messages postés
5
Date d'inscription
samedi 3 décembre 2011
Statut
Membre
Dernière intervention
16 décembre 2016
- 16 déc. 2016 à 12:13
Bonjour,

Je cherche à comparer des valeurs type texte entre elles afin de contrôler les saisie.
Par exemple :
un produit X de couleur rouge envoyer sur 2 à 7 sites. Je souhaite contrôler que les sites ayant reçu le produit en question aient bien indiqué rouge comme couleur reçu.

Produit/Entrepôt1/Entrepôt2/Entrepôt3/Entrepôt4/Entrepôt5/Entrepôt6/Entrepôt7/CONTROLE
X______/rouge____/___________/rouge____/___________/rouge____/__________/___________/ok
Y______/bleu______/vert______/bleu______/___________/bleu______/__________/bleu______/ko

Merci pour votre aide.

Cdlt

4 réponses

gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 610
16 déc. 2016 à 10:52
Bonjour,

Selon ton exemple, en I2 tu mets cette formule et tu tires sur la colonne.
=SI(NB.SI($B2:$H2;"rouge")=NBVAL($B2:$H2);"ok";"ko")

et le mieux ce serait que tu ais la couleur dans une colonne, par exemple :
=SI(NB.SI($B2:$H2;$J2)=NBVAL($B2:$H2);"ok";"ko")

0
mich2p1
Messages postés
5
Date d'inscription
samedi 3 décembre 2011
Statut
Membre
Dernière intervention
16 décembre 2016

16 déc. 2016 à 11:13
Bonjour,

J'ai pris une couleur pour simplifier mon exemple.

Ce que j'essaye de faire, c'est de matcher des réponses entre elles lorsqu'il y en a.
Les réponses peuvent être de toutes sortes mais doivent impérativement être identiques.
L'idée est de trouver une fonction de type "match" mais sans valeur de référence = valeurs affichées égales entre elles.

Merci
0
mich2p1
Messages postés
5
Date d'inscription
samedi 3 décembre 2011
Statut
Membre
Dernière intervention
16 décembre 2016

16 déc. 2016 à 11:38
Peut être qu'en décomptant le nombre d’occurrences des cellules non vides cela me permettrait de m'être en évidence tout ce qui diffère de 1 ?
0
gbinforme
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 610
16 déc. 2016 à 11:56
Bonjour,

Cela complique un peu la formule mais cela devrait fonctionner avec la fonction magique DECALER ;-)
=SI(NB.SI($B2:$H2;DECALER(A2;;EQUIV("";$B2:$H2;-1)))=NBVAL($B2:$H2);"ok";"ko")
0
mich2p1
Messages postés
5
Date d'inscription
samedi 3 décembre 2011
Statut
Membre
Dernière intervention
16 décembre 2016

16 déc. 2016 à 12:13
Parfait !

Merci.
0