La feuille de style ne répond pas [Résolu/Fermé]

Signaler
-
 philippef -
Bonjour,
Je suis devant un problème incompréhensible.
quand j'attribue un id à un div il ne se passe rien.
j'ai "ramassé" un virus en octobre mais le pc a été nettoyé. Normalement !!
Tout est encodé en UTF-8
la page index .php

<!DOCTYPE HTML>
<html>
<head>
<title>Association pour l'Animation Culturelle de Troissy~Bouquigny</title>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1, maximum-scale=1, user-scalable=no" />
<meta name="description" content="Association culturelle, Culture, Histoire, Troissy, Bouquigny, Champagne"/>
<meta name="keywords" content="Association, Culturel, Histoire, Crypte, Brocante, Champagne, Troissy, Bouquigny, Dormans, 51, 51700 "/>
<meta name="Robots" content="index, follow, all"/>
<meta name="Revisit-after" content="5 days"/>
<link rel="stylesheet" type="text/css" href="css/style.css">

</head>
<body>
<!---<div id="global">---!>
<div style="width:80%;background:yellow;">
toto


</div>
</body>
</html>


la feuille de style.css

#global {
width:80%;
background-color:yellow;
}

pensant que j'avais un problème avec EasyPhp, j'ai même téléchargé la dernière version. et du coup j'ai perdu ma table !!
[]

EDIT : Ajout du LANGAGE dans les balises de code (histoire d'avoir la coloration syntaxique...)

4 réponses

Messages postés
699
Date d'inscription
mercredi 8 avril 2009
Statut
Membre
Dernière intervention
4 décembre 2016
79
bonjour,

<!---<div id="global">---!>

la balise est en commentaire ....

ce n'est d'ailleurs pas comme çà que l'on insère un commentaire mais comme ceci :

<!-- commentaire -->
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
14733
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
12 octobre 2020
258
Tu indique que ton CSS est dans le chemin relatif :
css/style.css
Es-tu sûr que le CSS est bien à cet endroit.
oui je confirme que le fichier est bien à cet endroit : style.css dans le dossier css.
D'ailleurs la page index ne pose pas de problème. J'ai continué de coder et pour le moment je n'ai que ce problème qui subsiste avec le css.
J'ai déjà regardé un peu partout comment mettre deux div côte à côte et je ne vois pas pourquoi les miens ne veulent être côte à côte !!!
Messages postés
14733
Date d'inscription
vendredi 14 mars 2003
Statut
Modérateur
Dernière intervention
12 octobre 2020
258
L'idéal aurait été de fermer la balise :
<link rel="stylesheet" type="text/css" href="css/style.css" />

Sinon, avec un lien, tu arrive bien sur ton CSS quand tu cliques dessus ?
<a href="css/style.css" rel="nofollow noopener noreferrer" target="_blank">TestCss</a>
ok j'ai fermé la balise avec /> .
Rien de changé c'est toujours les 2 div qui ne se mettent pas l'un à côté de l'autre.
et toutes les autres pages s'affichent correctement (pour le moment)!!
Messages postés
160
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
22 mars 2020
25
Bonjour,

Vous pouvez également remplacer :
<body>
<!---<div id="global">---!>
<div style="width:80%;background:yellow;">

toto

</div>
</body>


Par :
<body>
<div id="global">

toto

</div>
</body>
Merci pour votre aide.
J'ai réécrit la page et le css et tout marche normalemet