Somme conditionnée par des dates

[Résolu/Fermé]
Signaler
Messages postés
6
Date d'inscription
vendredi 11 novembre 2016
Statut
Membre
Dernière intervention
17 février 2017
-
Messages postés
6
Date d'inscription
vendredi 11 novembre 2016
Statut
Membre
Dernière intervention
17 février 2017
-
Bonjour à tous,

je voudrai effectuer des calculs sur une colonne, en fonction de la date entrée dans une autre colonne, au format jj/mm/aaaa

J'ai en gros une colonne avec des dates de prestation et une colonne avec le tarif payé en face de la date

L'idée est de faire un total trié par mois (somme pour le mois de janvier, somme pour le mois de février, etc etc),

Merci d'avance pour votre aide

MaxEsth

3 réponses

Messages postés
16906
Date d'inscription
lundi 9 juin 2008
Statut
Contributeur
Dernière intervention
24 septembre 2021
901
Je pense que un "tableau croisé dynamique" fera exactement ce dont tu as besoin.
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 061
Bonsopir
à adapter:
de A2 à A100 les dates
de B2 à B100 les montants
la formule:

=SOMMEPROD((MOIS($A$1:$A$100)=1)*($B$2:$B$100))

....=1 pour janvier, 2 pour février etc....

ou alors si vous placez par exemple de C2 à C11 les noms des mois, en D2 à tirer sur la hauteur:
=SOMMEPROD((MOIS($A$1:$A$100)=LIGNE($A1))*($B$2:$B$100))


crdlmnt
Messages postés
6
Date d'inscription
vendredi 11 novembre 2016
Statut
Membre
Dernière intervention
17 février 2017

Merci, je ne connaissais pas la fonction "MOIS"

Je pense me débrouiller avec ça

Merci !