Formule de calcul dont la cellule contient un signe $ [Résolu/Fermé]

Signaler
Messages postés
1
Date d'inscription
mercredi 2 novembre 2016
Statut
Membre
Dernière intervention
2 novembre 2016
-
 Karpak -
Bonjour !

J'ai un problème. Je reçois de mes collègues américains un fichier Excel fabriqué de leur version anglaise, lequel j'ouvre dans ma version française. A priori, ça ne devrait pas avoir un impact sur mon problème, mais bref, je préfère le mentionner dès le début, au cas où....

Donc dans le fichier que je reçois, disons que
la cellule A1 contient l'info suivante: "$1,000"
la cellule A2 contient l'info "1.34"
Dans la cellule A3, ils ont mis la formule suivante =A1*A2

Quand j'ouvre le fichier, la cellule A3 affiche le résultat, soit $1,340
Mais si je fais F2 sur la cellule A3, et qu'ensuite je referme, le résultat de cette formule devient : #VALUE!

Comment se peut-il que sur l'ordinateur de mes collègues, les formules fonctionnent, mais pas sur le mien ? Nous utilisons tous la même version d'Excel, soit 2016 sous MS Office 365 ProPlus.

Et puisque les fichiers que j'aurai à utiliser sont nombreux et contiennent un grand volume de champs contenant des caractères, il serait vraiment important de trouver la solution, au lieu d'aller modifier manuellement tous les chiffres.... à moins qu'il existe une formule pour ça aussi ? :) Merci !

KARPAK

2 réponses


Bonjour KARPAK,

1) Je ne suis pas sûr de la solution que je vais te proposer.

2) Même si ça marche, les modifs à faire sont pour le temps
    d'utilisation du fichier Excel anglais ; donc après, si retour
    à un fichier Excel français, remettre les options comme
    c'était avant !

bouton Office (= Fichier), bouton « Options Excel » ; côté gauche,
choisir « Options avancées » ; côté droit, 1ère rubrique « Options
d'édition » :

☐ Utiliser les séparateurs système
    ☑ Séparateur de décimale : .
    ☑ Séparateur des milliers : ,

Si ton problème est réglé, merci d'aller en haut de page
pour cliquer sur « Marquer comme résolu ».

Cordialement.  😊
Bonjour Albkan, j'ai bien essayé mais ça ne fonctionne pas... Merci quand même, je vais devoir continuer à chercher. Cordialement, Karpak
Messages postés
25841
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 février 2021
5 795
Bonjour
confirmez vous que ce que vous avez écrit est bien ce que vous avez dans le fichier, soit
en A1 une virgule pour les décimales et en A2 un point?
car dans ce cas, une des deux cellules est un texte et le calcul ne peut pas se faire.

Suivant ce que dit Albkan, si votre séparateur est une virgule est que vous avez bien les deux cas dans les cellules, il faut remplacer le . par une virgule, ce qui peut nécessiter 2 temps de correction
1° sélection du champ de valeur / Touche ctrl et touche h
  • remplacer: tapez un point
  • par :tapez une virgule

2° si le problème ne s'arrange pas après cette manip
  • copiez une cellule vide
  • sélectionnez le champ/ clic droit / collage spécial / Ajouter

crdlmnt

Ps vérifier aussi le format de la cellule qui contient le signe $ devant la valeur, ce format ne peut être que personnalisé ou monétaire US), alors qu'en standard ou autre, c'est un texte. Dans ce cas, refaite une passe remplacer avec:
remplacer: $
par: ne mettez rien

La qualité de la réponse dépend surtout de la clarté de la question, merci!
Bonjour Vaucluse,

En fait, la cellule A1 sous-tend que le chiffre est $1,000.00
donc en fait, la vigule est le séparateur de milliers, et le point (.) est un séparateur de décimales (tel que la cellule A2 avec 1.34)

Et ce qui m'embête, c'est que c'est exactement ce fichier, avec ces cellules, que je reçois de mes collègues américains, et pour eux, le calcul se fait. Et je suis bien d'accord avec toi, le champ A1 me semble être un champ texte (car il inclut des caractères tels le $ et la virgule), quand A2 est purement un chiffre, mais comment expliquer que vous eux, aux USA, ça marche ?.... Rien à voir avec Trump j'espère... hahaha

Mais bref, j'ai essayé ta solution du Recherche/Remplace, en recherchant $ et remplaçant par "vide", et recherchant la vigule et remplaçant par "vide", et ça règle mon problème ! Donc ok, il va me falloir faire du Recherche/Remplace sur chacun des 52 fichiers, mais pas si mal pour régler le problème !

Un immense Merci !

KARPAK