Colorier une cellule en fonction d'une autre [Résolu/Fermé]

Signaler
Messages postés
70
Date d'inscription
lundi 15 juin 2015
Statut
Membre
Dernière intervention
21 novembre 2019
-
Messages postés
70
Date d'inscription
lundi 15 juin 2015
Statut
Membre
Dernière intervention
21 novembre 2019
-
Bonjour tout le monde,

Alors j'ai farfouillé le forum mais j'ai pas trouvé ce dont j'ai besoin.

J'ai Excel 2016
J'aimerais qu'une cellule se colorie automatiquement et de la même couleur qu'une autre cellule de la même ligne.

Je m'explique :

A1 Colonne A : Colonne B :
A2 NOM1 ENTREPRISE1
A3 NOM1 ENTREPRISE2

A4 NOM2 ENTREPRISE2

A5 NOM3 ENTREPRISE3
A6 NOM3 ENTREPRISE1

A7 NOM4 ENTREPRISE2

J'aimerai que si un même nom travaille avec plusieurs entreprise, alors la celulle A1 se colore.
Pour ça j'ai fait une mise en forme conditionnelle quand le nom est en doublon.
Jusque là ça va mais j'aimerais faire pareil pour la colonne B MAIS que par rapport à la couleur de la colonne A vu que je n'ai pas la possibilité de le faire directement étant donné qu'un nom ne peut pas avoir 2 fois la même entreprise.

Exemple :

A1 Colonne A : Colonne B :
A2 NOM1 (en vert) ENTREPRISE1 (en vert)
A3 NOM1 (en vert) ENTREPRISE2 (en vert)

A4 NOM2 (en rouge) ENTREPRISE2 (en rouge)

A5 NOM3 (en vert) ENTREPRISE3 (en vert)
A6 NOM3 (en vert) ENTREPRISE1 (en vert)

A7 NOM4 (en rouge) ENTREPRISE2 (en rouge)

J'espère que j'ai été compréhensible.
Merci de votre réponse !


A voir également:

2 réponses

Messages postés
1870
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
22 janvier 2021
54
Liitch, Bonjour.

Essayez ceci:

• Sélectionner: A1:B6
• Mise en forme conditionnelle: utilisez une formule:

=NB.SI($A$1:$A$6; $A1) >1

• Choisir un format prédéfinit ou personnaliser
• Puis "OK"

J'ai créé un petit exemple pour vous.
https://www.cjoint.com/c/FJcn4MtB6F1

Il était ce que vous vouliez?
J'espère que je vous ai aidé.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Messages postés
70
Date d'inscription
lundi 15 juin 2015
Statut
Membre
Dernière intervention
21 novembre 2019

Mazzaropi, Bonjour

Merci ! Ça a marché !
Et du coup à l'inverse ? Pour colorer les cellules "seules"
J'ai essayé la formule : =NB.SI($A$1:$A$6; $A1) <1
Mais ça n'a pas fonctionné j'ai sûrement du faire une erreur

Par contre si je fais cette mise en forme conditionnelle, est ce que ça reste possible de colorier la cellule d'une autre couleur manuellement ?
Messages postés
1870
Date d'inscription
lundi 16 août 2010
Statut
Contributeur
Dernière intervention
22 janvier 2021
54
Liitch, Bonjour.

Pour un format complet, vous pouvez faire ceci:

• Sélectionner: A1:B6
• Mise en forme conditionnelle: utilisez une formule:

Règle 1:

=NB.SI($A$1:$A$6; $A1) >1

• Choisir fond de couleur: VERT.
• Puis "OK"

Règle 2:

=NB.SI($A$1:$A$6; $A1) =1

• Choisir fond de couleur: ROUGE.
• Puis "OK"

Il était ce que vous vouliez?
J'espère que je vous ai aidé.
--
Belo Horizonte, Brasil.
Marcílio Lobão
Messages postés
70
Date d'inscription
lundi 15 juin 2015
Statut
Membre
Dernière intervention
21 novembre 2019

Bonjour à toi,

Merci beaucoup ça fonctionne comme je le voulais !