Formule somme si [Résolu/Fermé]

Signaler
-
 KATEkate77 -
Bonjour,
Pourriez-vous m'aider s'il vous plaît pour trouver une formule.
Dans la colonne M, j’aimerai faire la somme de la colonne J dès qu’on rencontre un autre nom dans la colonne A

Voici la formule actuelle dans la colonne M : =SI(NBVAL(A14)=1;SOMME(J14:J18);" ")

Soit sur la première ligne

Colonne Colonne Colonne
A J M
AAAAA 50.76 € 113.52
6.00 €

50.76 €
6.00 €

BBBBB 236.04 € 248.04
6.00 €
6.00 €


Soit sur la dernière ligne
Colonne Colonne Colonne
A J M
AAAAA 50.76 €
6.00 €

50.76 €
6.00 € 113.52

BBBBB 236.04 €
6.00 €
6.00 € 248.04



Merci de votre aide;
Kate77

4 réponses

Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Bonjour
ce serait plus simple à faire si vous admettiez de faire le total sur la dernière ligne du même texte avec cette formule en commençant en A2:

=SI(A3="";"";SOMME($J$2:J2)-SOMME($M$1:M1))


à condition de renter un texte en ligne avec la dernière valeur en bas de liste en A (underscore suffit)
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
54288
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
16 267
Bonjour.

Tableau difficile à appréhender.
Prière de joindre le fichier Excel
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (15 Mo maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu fais un clic-droit dessus et tu choisis "Copier le lien"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse
tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Re
pour continuer mon message précédent:
vous pouvez aussi pour rester simple et si c'est possible:
reporter le texte sur toutes les lignes pour ne pas laisser de vide en A et utiliser cette formule en A2 à tirer sur la hauteur
=SI(NB.SI($A$2:A2;A2)=1;SOMME.SI(A:A;A2;J:J);"")

(il est possible masquer les doublons via une mise en forme conditionnelle)
crdlmnt
La qualité de la réponse dépend surtout de la clarté de la question, merci!
Merci à Vaucluse et Raymond pour votre aide.
J'ai choisi la réponse de Vaucluse qui me parait plus facile. J'ai enregistré mon tableau Je vous joins le lien pour le visualiser.
Dans l'onglet feuille 2, la solution de Vaucluse.
Dans l'onglet feuille 3, la solution de Raymond (pas réussi)
PS ; je suis sous Linux, j'espère que vous pourrez voir mon tableau)
Merci encore de votre aide précieuse.
Kate77

http://www.cjoint.com/c/FIfsHdgpZGH
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
5 992
Re
la proposition avec NB.SI ne peut pas fonctionner si vous avez plusieurs fois les mêmes ensembles de texte dans le tableau, il faut donc en rester à la 1°
par contre, je pense que la formule dans votre modèle est mal calée en démarrant pour A3 au lieu de A5, voyez ici avec la formule modifiée

soit si vous ne pouvez pas lire le fichier, en M5:

=SI(A6="";"";SOMME($J$5:J5)-SOMME($M$1:M1))

https://www.cjoint.com/c/FIfs4O1IJKl

crdlmnt
>
Messages postés
26106
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021

Merci encore Vaucluse,
Effectivement je ne peux pas lire le fichier, j'ai donc copier la formule.
PS : je vous remercie beaucoup car je suis en CDD et cela m'aide beaucoup pour conserver mon emploi et à mon âge (59ans) ....
Bonne fin de soirée.
Kate77
Messages postés
54288
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021
16 267 > KATEkate77
Euh, Kate, je précise que je n'ai envoyé aucune formule !
Les deux sont de mon ami Vaucluse, toujours disponible et efficace,
et que je salue ici ...
>
Messages postés
54288
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
23 juillet 2021

c'est vrai,mais vous m'avez répondu si vite, je ne savais pas et je n'osais pas joindre un fichier. Mais avec vos explications, j'ai passé le pas. Merci encore.
A la prochaine fois.
Bonne soirée
Kate77