Créer un classement avec nom joueur et points /ordre décroissant

[Fermé]
Signaler
Messages postés
16
Date d'inscription
lundi 18 janvier 2016
Statut
Membre
Dernière intervention
31 août 2016
-
Messages postés
16
Date d'inscription
lundi 18 janvier 2016
Statut
Membre
Dernière intervention
31 août 2016
-
Bonjour à tous,

Je fais appel à vos compétences.
Je possède un tableau Excel qui sert à gérer une compétition sportive.

Sur la première page, l'objectif est d'afficher automatiquement et par ordre décroissant le classement dans les cases 27 à 46 avec :
Colonne B : 1, 2, 3 etc... le rang de chaque sportif.
Colonne C : son nom.
Colonne F : ses points.

Sachant que les colonnes B, C, F vont chercher les données plus bas dans le feuillet dans les cases 56 à 279 avec :
Colonne F : nom du joueur.
Colonne I : points du joueur.

La question est donc : quelles formules mettre dans les colonnes B, C, F dans les cases 27 à 46 pour afficher correctement de manière décroissante le rang, le nom et les points des 20 meilleurs joueurs dont les données sont situées dans les cases 56 à 279.

Un grand merci si vous savez :)

A voir également:

3 réponses

Messages postés
26220
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
Bonjour

Pour le premier, à tirer sur la hauteur utile:

=SIERREUR(INDEX(F:F;EQUIV(GRANDE.VALEUR(I:I;LIGNE($A1);I:I;0));"")

le code SIERREUR sert à éviter un affichage d'erreur quand la liste est complète.

Cette formule n'utilise pas le rang inscrit en B car les ex-æquo sont édités à la suite les uns des autres, d'où l'utilité de ne pas inscrire cette numérotation au clavier mais plutôt de l'éditer avec cette formule

=SIERREUR(RANG(I2;I:I);"")

qui vous donnera le classement plus juste (genre 1,1 3,4,5,5,7 etc...)

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!es
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Bonjour,

Avec toutes ses informations, on peut construire une formule, néanmoins pour plus de simplicité, il pourrait interessant d'avoir le fichier sous les yeux.
Si il y a des informations confidentielles, n'hésite pas à créer un fichier test avec des informations bidons.

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...


Cordialement,

Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
1erement :
Sachant que les colonnes B, C, F vont chercher les données plus bas dans le feuillet dans les cases 56 à 279 avec :
Colonne F : nom du joueur.
Colonne I : points du joueur.


Dans la colonne E : en E56 puis à glisser jusqu'en E279.
=RANG(I56;$I$56:$I$279)+NB.SI($I$56:I56;I56)-1

2emement :

Sur la première page, l'objectif est d'afficher automatiquement et par ordre décroissant le classement dans les cases 27 à 46 avec :
Colonne B : 1, 2, 3 etc... le rang de chaque sportif.
Colonne C : son nom.
Colonne F : ses points.

Dans la colonne B :

B27 : 20
B28 : 19
...
B46 : 1

Dans la colonne C :
=RECHERCHEV(B27;$E$26:$I$279;2;FAUX)

dans la colonne F :
=RECHERCHEV(B27;$E$26:$I$279;5;FAUX)

Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
Messages postés
16
Date d'inscription
lundi 18 janvier 2016
Statut
Membre
Dernière intervention
31 août 2016

En fait, j'ai trouvé : le problème vient du fait que la colonne des noms soit avant celle où l'on trouve le classement... Il faut donc que je mette le classement en E effectivement, puis le nom en F.
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Les valeurs à rechercher doivent être dans la première colonne de ta table de recherche effectivement :)
Messages postés
16
Date d'inscription
lundi 18 janvier 2016
Statut
Membre
Dernière intervention
31 août 2016

Eh oui, j'ai fait le changement, cela fonctionne...
Autre problème, je souhaite différencier hommes et femmes, donc comment faire pour que la recherche de valeur =RECHERCHEV(A2;$E$3:$I$10;3;FAUX) ne prenne pas en compte la cellule G par exemple (dans ce cas, cela reviendrait à établir le classement Hommes en ne prenant pas en compte la cellule G qui donne le classement des femmes) ?
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Il faudrait que j'ai le fichier sous les yeux pour pouvoir comprendre plus dans les détails ta demande.

La formule que tu me donnes n'est pas celle que je t'ai donnée , je ne connais pas la valeur de A2 , ni ce qu'il y a entre E3 et I10.

Qu'est ce qu'il y a dans la colonne G ?
Messages postés
16
Date d'inscription
lundi 18 janvier 2016
Statut
Membre
Dernière intervention
31 août 2016

C'est bon j'ai trouvé la solution pour cette histoire hommes / femmes.
Par contre, en cas d'égalité, il ne met que le nom du 1er et se met du coup en erreur pour le choix du 2è... alors qu'il faudrait qu'il mette en 2è le nom du 1er... bref, je vais me débrouiller avec tout ça. Merci :)