Créer un classement avec nom joueur et points /ordre décroissant

Fermé
drakar3 Messages postés 16 Date d'inscription lundi 18 janvier 2016 Statut Membre Dernière intervention 31 août 2016 - 31 août 2016 à 08:36
drakar3 Messages postés 16 Date d'inscription lundi 18 janvier 2016 Statut Membre Dernière intervention 31 août 2016 - 31 août 2016 à 11:33
Bonjour à tous,

Je fais appel à vos compétences.
Je possède un tableau Excel qui sert à gérer une compétition sportive.

Sur la première page, l'objectif est d'afficher automatiquement et par ordre décroissant le classement dans les cases 27 à 46 avec :
Colonne B : 1, 2, 3 etc... le rang de chaque sportif.
Colonne C : son nom.
Colonne F : ses points.

Sachant que les colonnes B, C, F vont chercher les données plus bas dans le feuillet dans les cases 56 à 279 avec :
Colonne F : nom du joueur.
Colonne I : points du joueur.

La question est donc : quelles formules mettre dans les colonnes B, C, F dans les cases 27 à 46 pour afficher correctement de manière décroissante le rang, le nom et les points des 20 meilleurs joueurs dont les données sont situées dans les cases 56 à 279.

Un grand merci si vous savez :)

A voir également:

3 réponses

Vaucluse Messages postés 26495 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 8 avril 2022 6 284
Modifié par Vaucluse le 31/08/2016 à 09:14
Bonjour

Pour le premier, à tirer sur la hauteur utile:

=SIERREUR(INDEX(F:F;EQUIV(GRANDE.VALEUR(I:I;LIGNE($A1);I:I;0));"")

le code SIERREUR sert à éviter un affichage d'erreur quand la liste est complète.

Cette formule n'utilise pas le rang inscrit en B car les ex-æquo sont édités à la suite les uns des autres, d'où l'utilité de ne pas inscrire cette numérotation au clavier mais plutôt de l'éditer avec cette formule

=SIERREUR(RANG(I2;I:I);"")

qui vous donnera le classement plus juste (genre 1,1 3,4,5,5,7 etc...)

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!es
1