Fonctions Si, ET, OU imbriqués

Résolu/Fermé
Audeline - 20 juil. 2016 à 11:26
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
- 20 juil. 2016 à 13:09
Bonjour à tous,

Cela fait 2 jours que je planche sur un cas et pas moyen de trouver une formule correcte, je m'explique:
Il y a: Le niveau de poste attendu avec 3 niveaux (non compétent/Essentiel/Expert) et celui détenu (non compétent/Essentiel/Expert).
J'aimerai insérer une formule qui permette de dire si la personne doit développer ses compétences en fonction du niveau attendu et détenu.
Exp: Si niveau attendu A1= "Essentiel" et que niveau détenu A2= "Non compétent" alors A3= "A développer" Si niveau attendu A1="Essentiel" et que niveau détenu A2="Expert" alors A3="OK" et ainsi de suite.
Du coup je ne sais pas quelle formule utilisée, Si ET OU imbriqués ou plusieurs SI ou plusieurs ET, AU SECOURS!!!!



2 réponses

Fahora
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
20 juil. 2016 à 11:36
Bonjour ,

voilà comment moi je l'aurais fait.
Il y a peut être plus rapide, plus simple

https://www.cjoint.com/c/FGujKjL0ziH

cordialement,
0
Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016

20 juil. 2016 à 12:04
Merci Fahora :) j'y avait pensé mais comme je voulais m'épargner des colonnes en plus car je voulais faire un tableau très synthètique, mais c'est top! MERCI Je vais tester sur mon fichier dans son ensemble.
0
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
528
20 juil. 2016 à 11:43
Bonjour,

Autre solution :
=SI(EQUIV(A2;{"non compétent";"Essentiel";"Expert"};0)<EQUIV(A1;{"non compétent";"Essentiel";"Expert"};0);"A développer";"OK")

A+
0
Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016

20 juil. 2016 à 12:04
Bonjour Gyrus,

Je vais tester sur mon fichier, je ne connaissais pas du tout cette fonction!
0
Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016
> Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016

20 juil. 2016 à 12:05
MERCI!
0
Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016
> Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016

20 juil. 2016 à 12:16
Je viens de tester sur mon fichier et juste WAHOU!!!!!!

Par contre j'essaie de comprendre le fonctionnement pour pouvoir l'adapter à d'autres circonstances pourrais-tu m'expliquer son raisonnement?
0
Gyrus
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
528 > Audeline10
Messages postés
4
Date d'inscription
mercredi 20 juillet 2016
Statut
Membre
Dernière intervention
20 juillet 2016

20 juil. 2016 à 13:09
Pour le niveau attendu, la formule
=EQUIV(A2;{"non compétent";"Essentiel";"Expert"};0)
,
renvoie la position de l'élément cherché (valeur de A2) dans la liste des 3 éléments {"non compétent";"Essentiel";"Expert"}.
Si A2 contient "non compétent", la formule renvoie 1.
Si A2 contient "Essentiel", la formule renvoie 2.
Si A2 contient "Expert", la formule renvoie 3.
Cela permet d’obtenir directement un niveau de compétence.

Idem pour le niveau détenu avec la formule
=EQUIV(B2;{"non compétent";"Essentiel";"Expert"};0).


Il suffit donc ensuite de comparer les 2 niveaux de compétences et afficher le résultat de la comparaison.
=SI("niveau attendu" < "niveau détenu"; "A développer";"OK")

A+
0