404 avec WordPress
Résolu
Bonjour,
Après changement d'hébergement (je m'héberge moi-même désormais), de BDD et installation d'un certificat SSL, mon site WordPress me renvoie une erreur 404 pour toutes les pages, sauf la page d'accueil...
Petites précisions :
Merci d'avance de votre aide
Cordialement
Après changement d'hébergement (je m'héberge moi-même désormais), de BDD et installation d'un certificat SSL, mon site WordPress me renvoie une erreur 404 pour toutes les pages, sauf la page d'accueil...
Petites précisions :
- mod_rewrite est activé
- J'ai déjà essayé de modifier et de rétablir les options des permaliens
- Mon .htaccess est correct
root@PL001:/var/www/html# cat .htaccess
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPressroot@PL001:/var/www/html#
- les pages tels que le forum (/forum/) ne sont pas accessibles
Merci d'avance de votre aide
Cordialement
2 réponses
-
j'y connais pas grand chose en serveur mais pourquoi mettre la ligne root dans ton htaccess (au lieu de la config serveur) puisque wordpress sait normalement où est le fichier
ps: est ce que tu as modifier les liens dans le menu réglages de wordpress en https puisque tu est en ssl ?
Avec un ordinateur, on peut faire plus rapidement des choses qu’on n’aurait pas eu besoin de faire sans ordinateur.-
-
@pierre.lagouttecomme j'ai modifié mon post après ta réponse (ou en même temps), est ce que tu as mis https dans les liens du menu réglages ?
-
@elgazarOui ça a été fait. J'ai finalement trouvé : Je n'avais pas activé AllowOverride dans la config apache.
Merci à toi d'avoir essayé :D
-
-
Petite précision, dans mon interface admin, j'ai Default_permalink_notice Dismiss qui s'affiche.