Copiage d'une cellule selon la valeur de 2 autres

[Résolu/Fermé]
Signaler
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016
-
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
-
Bonjour,

Je souhaiterais savoir si une formule ou un macro ou une mise en forme conditionnelle qui permettrait de copier une cellule n°1 à la colonne d'une ligne où figure une cellule n° 2 si celle-ci est identique à une cellule n°3, adjacente à la cellule n°1...

Exemple : si cellule H3 = A10, copier la valeur de la cellule I3 en G10
si cellule H15 = A80, copier la valeur de la cellule I15 en G80 ...

Merci.



3 réponses

Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744
Bonjour.

En G10, saisir la formule =SI(H3=A10;I3;"")
En G80, saisir la formule =SI(H15=A80;I15;"")

... les considérations relatives à des cellules adjacentes, à des lignes ou à des colonnes sont inutiles ici.
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

Je me suis sans doute mal exprimé.

Je souhaiterais si x, y ou z = cellule A3,....ou A800, copier la cellule adjacente à x, y ou z en H3.... ou H000.
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744
Nn ; c'est bien ça ... tu copies cette formule dans les cellules H3 ... H800
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

J'ai fait un essai et ça ne fonctionne pas.
Si H3 n'est pas égal à A10, la cellule indique err:518.
Je souhaite que soit trouvée où est la cellule en colonne A égale à H3 et copier I3 à la ligne où de cette cellule. Il faudrait que je fasse la formule avec H3 égal A10, A11, A12... jusqu'à A800 et faire de même avec H4 jusqu'à H 800.
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744
Ceci est tout-à-fait différent de la demande initiale ...
ou alors nous n'avons la même façon de lire un texte !

Cette nouvelle formulation implique qu'il faudrait une macro, ce qui n'est pas dans mes compétences. Désolé.
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

Il me semblait bien qu'on ne s'était pas compris...
Solution trouvée avec la fonction RECHERCHEV. Merci quand même.
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744 >
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

Du coup, je serais assez curieux de voir ta formule
(et peut-être même tout le fichier) ...
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

J'ai utilisé les fonctions INDEX et EQUIV finalement :
=INDEX($Z$3:$Z$833;EQUIV(D3&F3;$Z$3:$Z$833&$AF$3:$AF$833;0))

Concrètement (après plusieurs retraitements qui font que ce ne sont plus les mêmes colonnes que citées au sujet) :
j'avais des données en colonnes A à I et d'autres données en colonnes Z à AF. Les données sur chaque ligne entre A et I étaient liées et les données situées sur chaque ligne entre Z et AF étaient liées. Mais A-I et Z-AF n'étaient pas liées sur chaque ligne. Ainsi A-I en ligne 3 pouvait correspondre à Z-AF en ligne 200.

Il fallait que je trouve dans la zone de colonnes Z-AF, qui fait 833 lignes, la ligne correspondant à celle située dans la zone A-I.

Je voulais mettre en ligne 3 des colonnes J à P le contenu correspondant aux données de la ligne 3 des colonnes A à I, et ainsi de suite jusqu'à A833-I 833.

Ainsi la formule ci-dessus créée sur J3 permet de copier la donnée de Z pour laquelle Z et AF correspondent à D3 et F3. Au cas présent, les données de D3 et F3 étaient en Z 825 et AF 825, donc Z825-AF825 correspondent à A3-I3, donc Z825 a été mis en J3 par cette formule. La même formule collée sur K3, L3 ... P3 a permis de mettre sur ces cellules AA825, AB825... AI825.

J'ai ensuite coller la formule su J33-P833.

Je ne peux malheureusement donner le fichier qui comprend des données confidentielles.
Messages postés
54840
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
17 octobre 2021
16 744 >
Messages postés
10
Date d'inscription
samedi 12 avril 2008
Statut
Membre
Dernière intervention
4 juillet 2016

Merci de tes explications.
Elles ne correspondent guère à ce que tu as indiqué dans tes premiers messages, qui m'ont conduit à te diriger vers une macro.
Et j'étais extrêmement surpris que RECHERCHEV puisse t'apporter la solution, d'où mon interrogation ...
Mais tant mieux et bravo, que tu aies trouvé la réponse à ton problème !