Recopie de la formule d'une cellule vers une autre cellule

Fermé
fofojoli
Messages postés
2
Date d'inscription
jeudi 9 juin 2016
Statut
Membre
Dernière intervention
10 juin 2016
- 9 juin 2016 à 22:26
didmed
Messages postés
2625
Date d'inscription
dimanche 19 décembre 2004
Statut
Membre
Dernière intervention
25 septembre 2022
- 9 juin 2016 à 23:09
Bonjour Messieurs,

Je voudrais avoir votre assistance, pour résoudre un problème que je rencontre lors de la copie de la formule d'une cellule vers une autre cellule, tout en reconduisant une constante qui se trouve dans la formule.

Voici les détails:
Je travaille dans une feuille excel où j'ai positionné la valeur "8" dans la cellule K1.

La valeur "8" est une constante que je peux décider de modifier à tout moment, en fonction du résultat escompté.

Dans les cellules B4 C4 D4, j'ai respectivement les valeurs 2 3 8.

Dans la cellule E4, à partir de la formule suivante: =B4+C4+D4, j'obtiens bien le résultat 13 qui est bien la somme de 2+3+8.

J'ai l'intention de tester la valeur inscrite dans chacune des cellules B4 C4 et D4 par rapport à la valeur se trouvant dans la cellule K1 (c'est à dire "8").

Pour ce faire:
1 - Dans la cellule F4, je pose la condition suivante: =SI(B4=K1;"Oui";"")
Résultat: j'obtiens bien du blanc (" "), ce qui est normal, puisque "2"est
différent de "8".


2 - Dans la cellule G4, (pour ne pas ré-écrire caractère par caractère la condition, je recopie le contenu de la cellule F4 dans G4 et j'obtiens ceci:

=SI(C4=L1;"Oui";""). Ici, le K1 est transformé en L1.

Comment faire pour garder K1 dans la cellule G4 lors de la recopie, pour avoir la formule suivante:

=SI(C4=K1;"Oui";"").


Si cela marche, alors j'aurai à faire le même type de recopie vers la cellule H4.



Dans l'attente, je vous prie de recevoir, Messieurs, mes salutations distinguées.

Remerciements.

2 réponses

DjiDji59430
Messages postés
3647
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
25 septembre 2022
554
9 juin 2016 à 23:04
Bonjour,

en travaillant en ref absolue

=SI(C4=$K$1;"Oui";"").

Crdmt
0
didmed
Messages postés
2625
Date d'inscription
dimanche 19 décembre 2004
Statut
Membre
Dernière intervention
25 septembre 2022
805
9 juin 2016 à 23:09
Salut

Essaies cette valeur en F4:
=SI(B4=$K$1;"Oui";"")

Normalement, en copiant, la variable K1 désignée $K$1 restera !


@+
0