NB.SI.ENS (2 critères + période)

Résolu/Fermé
Messages postés
131
Date d'inscription
lundi 18 mai 2015
Statut
Membre
Dernière intervention
10 mai 2016
-
Messages postés
131
Date d'inscription
lundi 18 mai 2015
Statut
Membre
Dernière intervention
10 mai 2016
-
Bonjour,

Je suis désespérement à la recherche d'une formule que je n'écris pas correctement...

Je m'explique :
- J'ai en colonne J, le nom de mes commerciaux.
- J'ai en colonne G, des dates de fin de contrat.

Je cherche :
- Le nombre de contrat pour un commercial pour le mois de janvier.

Pour l'instant, j'ai écris ça :

=NB.SI.ENS(G$1:G$500;"JANVIER"; J$1;J$500; "COMMERCIAL1")

Mes dates sont écris sous ce format : 01/01/2016.

J'espère que je suis clair et que vous pourrez m'aider.

Bien cordialement

1 réponse

Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 191
Bonjour
vous devez utiliser le mois pour retrouver vos données, ce qui ne convient pas à NB.SI.ENS ( "JANVIER" est un texte)

essayez avec:

=SOMMEPROD((MOIS($G$1:$G$500)=1)*(J$J$1:$J$500="COMMERCIAL1"))

=1 pour janvier = 2 pour février etc..

Ou alors:

=SOMMEPROD((MOIS($G$1:$G$500)=LIGNE(A1))*(J$J$1:$J$500="COMMERCIAL1"))

pour tirer la formule vers le bas et avoir les 12 mois automatiquement

crdlmnt



Messages postés
131
Date d'inscription
lundi 18 mai 2015
Statut
Membre
Dernière intervention
10 mai 2016
49
Bonjour Vaucluse.

Je n'arrive pas à utiliser vos solutions. J'obtiens un #valeur! avec les 2 formules.

=SOMMEPROD((MOIS(Feuil1!G$1:G$500)=LIGNE(A1))*(Feuil1!J$1:J$500="MANABE"))
=SOMMEPROD((MOIS(Feuil1!G$1:G$500)=1)*(Feuil1!J$1:J$500="MANABE"))

Pour information, je vais très certainement dérouler la formule à l'horizontal. J'ai les 12 mois en colonne C à N et mes 6 commerciaux en ligne 3 à 8.
Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 191
petite erreur de ma part dans la proposition SOMMEPROD...!
il faut si vous utilisez le code MOIS()=1 faire référence à la colonne date donc E et pas G

=SOMMEPROD((MOIS(Feuil1!E$1:E$500)=LIGNE(A1))*(Feuil1!J$1:J$500="MANABE"))

par ailleurs le coçde LIGNE(A1) ne s'incrémentera que si vous tirez la cellule à la verticale. Pour incrémenter à l'horizontal, il faut utiliser COLONNE(A1)

mais dans les deux cas, il ne faut pas qu'il y ait de cellules intercalées

Alors il est peut être aussi simple de copier coller la formule avec =1 et de corriger à chaque poste de =1 en =2 , ect.. jusqu'à 12 pour Décembre

crdlmnt
Messages postés
131
Date d'inscription
lundi 18 mai 2015
Statut
Membre
Dernière intervention
10 mai 2016
49
Finalement, j'ai fait un nouvelle colonne avec mois(G1) en colonne M, puis j'ai utilisé cette formule :

=NB.SI.ENS(Feuil1!$M$1:$M$500;"1"; Feuil1!$J$1:$J$500;"MANABE")

Le 1 correspondant à Janvier donc.