Nombre de *

Résolu/Fermé
NZT9 - 29 avril 2016 à 22:25
NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016 - 30 avril 2016 à 15:03
Bonjour,


J'aurais pu faire autrement mais j'ai choisi de noter mes critères avec des étoiles (*) mais je n'arrive pas à en faire un total à la fin de ma ligne.

Pouvez-vous m'aider?

Merci beaucoup!

5 réponses

Gyrus Messages postés 3334 Date d'inscription samedi 20 juillet 2013 Statut Membre Dernière intervention 9 décembre 2016 523
29 avril 2016 à 22:32
Bonjour,

Essaie avec une formule du type
=SOMMEPROD((A1:A100="*")*1)

A+
0
Bonsoir Gyrus,

La formule ne marche pas, le résultat est 0 :(
0
The_boss_68 Messages postés 928 Date d'inscription dimanche 15 novembre 2015 Statut Membre Dernière intervention 10 juin 2024 177
29 avril 2016 à 22:54
Bonsoir, NZT9

Juste pour dire la formule de Gyrus fonctionne, mais si tu veux tester celle-ci elle fonctionne aussi "formule à mettre en b1"

=NBVAL(A1:A100)


Slts
0
NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016
Modifié par NZT9 le 29/04/2016 à 23:59
Oui, les formules en soi marchent mais elle ne font pas ce que je veux faire.
Celle de Gyrus compte le nombre de fois où une étoile apparait et la tienne compte le nombre de cellules qui contiennent une étoile.

Je vais vous mettre une capture d'écran pour que vous compreniez mieux ce que je veux faire :


Ce que je veux faire c'est compter le nombre total d'étoiles sur la ligne correspondant à mes critères :)
0
eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024 7 225
30 avril 2016 à 00:09
Bonjour,

Tu aurais dû mettre des étoiles blanches...
=SOMMEPROD(NBCAR(A2:I2))

eric
0
NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016 > eriiic Messages postés 24584 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 18 juin 2024
30 avril 2016 à 14:43
Je ne comprends pas pourquoi des étoiles blanches mais super merci beaucoup ta réponse marche très bien Eric!
0
Raymond PENTIER Messages postés 58507 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 135 > NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016
30 avril 2016 à 14:46
C'est pour te faire comprendre que c'est pénible à lire, tes étoiles jaune pâle !
Alors pourquoi ne pas les mettre en gris ou carrément blanches, tant qu'on y est ...
0
Raymond PENTIER Messages postés 58507 Date d'inscription lundi 13 août 2007 Statut Contributeur Dernière intervention 20 juin 2024 17 135
30 avril 2016 à 14:49
"Ce que je veux faire c'est compter le nombre total d'étoiles sur la ligne"
Tu aurais pu le dire dès ton premier message, ou joindre ton fichier (et pas une simple image) ; on aurait tout de suite compris, et tu aurais eu ta réponse au bout de 10 minutes !

Cordialement.
0
NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016
30 avril 2016 à 15:02
Haha ça semblait logique pour moi.
Je savais même pas qu'on pouvait joindre le fichier.
C'est la première fois que j'utilise le forum, ce sera parfait la prochaine fois :)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Utilisateur anonyme
30 avril 2016 à 00:30
Bonjour NZT9,

Ta capture d'écran n'ayant pas d'en-têtes de lignes et de colonnes,
je fais ces 2 suppositions :

a) Tes colonnes vont de A à I
b) Ta 1ère ligne d'* est la ligne 2

Entre alors cette formule en J2 et valide par < Ctrl >< Maj >< Entrée > :
=SOMME(NBCAR(A2:I2))

Tu dois alors obtenir la même formule encadrée de 2 accolades, car c'est
une formule matricielle : {=SOMME(NBCAR(A2:I2))}

Pour les autres lignes, étires (comme d'habitude) ta formule vers le bas.

Si ça règle ton problème, penses à utiliser le lien situé sous le 1er titre :
« marquer comme résolu ».

Cordialement.  😊
 
-2
NZT9 Messages postés 6 Date d'inscription vendredi 29 avril 2016 Statut Membre Dernière intervention 2 octobre 2016
30 avril 2016 à 15:03
Merci Albkan d'avoir pris le temps de répondre mais la réponse au-dessus était plus adaptée :)
0