Associer 2 cellules à un résultat

Résolu/Fermé
tonio - 20 avril 2016 à 17:54
 tonio - 27 avril 2016 à 11:47
Bonjour,

J'aimerais savoir comment faire pour associer 2 cellules provenant toutes deux d'une liste déroulante à un résultat.
Par exemple:
Si A2 contient "Coca" et C2 contient "Réunion" renvoyer 1 en D2.
Ou
Si A2 contient "Coca" et C2 contient "Evènement" renvoyer 1,5 en D2.
etc

Merci par avance

6 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 272
20 avril 2016 à 17:56
Bonjour
=SI(ET(A2="coca";C2="Réunion");1;SI(ET(A2="coca";C2="Evènement");1,5;""))

mais si vous avez un grand nombre de combinaison, il faudra voir les choses autrement
et pour vous aider, il faudra nous en dire plus
crdlmnt
0
Bonjour Vaucluse,
Je vous remercie pour votre réactivité.
Effectivement, il y'a un grand nombre de combinaisons possibles une centaine je pense.
Que souhaitez vous savoir de plus?
0
ccm81
Messages postés
10463
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 septembre 2022
2 315
24 avril 2016 à 18:46
Bonjour

en D2
=SI(A2="coca";SI(C2="Réunion";1;SI(C2="Evenement";1,5;"???")))
Mais le etc en fin de ton message, laisse supposer que ce n'est pas fini !!!

Clmnt
0
Bonjour,
Effectivement, comme j'ai pu le dire précédemment, il existe une centaine de solutions possibles. Pour ces raisons, existe-t-il une autre solution?
cdt
0
ccm81
Messages postés
10463
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 septembre 2022
2 315
25 avril 2016 à 11:28
Bonjour

Peut être faudra t'il passer par vba
Peux tu envoyer un bout de ton fichier, sur cjoint.com et joindre le lien obtenu à ton prochain message. N'oublies pas d'y ajouter des explications et des exemples de résultat attendu.

Cdlmnt
0
Voici le lien: http://www.cjoint.com/c/FDzj0CADhT0
Concrètement,
j'aimerais que dans la feuille "Journal entrées et sorties", cellule G8 apparaisse le Prix de Vente associé à la boisson sélectionnée en C8 en fonction du type de sortie séléctionnée en F8.
Les différents Prix de Vente figurent dans la feuille "PV".
J'espère être assez compréhensible...
Merci à vous
0
Bonjour,
Sinon avec la formule sommeprod ça peut répondre à plusieurs critères OU.. Dans votre exemple en D2:

=SOMMEPROD((A2="Coca")*(C2="Réunion"))+SOMMEPROD((A2="Coca")*(C2="Evènement"))*1,5
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
ccm81
Messages postés
10463
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 septembre 2022
2 315
25 avril 2016 à 16:25
Une solution
http://www.cjoint.com/c/FDzoy1UjusQ

Cdlmnt
0
Super ça fonctionne!
Je vous remercie.
J'aurais aimé que vous m'expliquiez si possible...

cdt
0
ccm81
Messages postés
10463
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
21 septembre 2022
2 315
26 avril 2016 à 15:46
De rien

le même avec quelques explications et suppléments
http://www.cjoint.com/c/FDAnTuQpYlQ

Cdlmnt
0
Merci beaucoup.
0
J'essaie maintenant que le fournisseur s'affiche dans la colonne d'à côté,uniquement lorsque la colonne "Entrée"(colonne D) contient une valeur.
J'ai essayé de suivre la même démarche.
J'ai ainsi entré les fournisseurs pour chaque boisson; suite à quoi j'ai attribué un nom à cette plage.
la formule suivante fonctionne
=(INDEX(FOURNISSEURS;EQUIV(C9;Boisson;0)))
Cependant je veux qu'elle s'active uniquement quand la colonne contient une valeur.
Je ne sais comment faire...
0
J'ai trouvé seul!
Je vous dérange pas plus!
Merci
0