Comment calculer écart type sous deux criteres [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016
-
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016
-
Bonjour,
je cherche, mais en vain, une fonction similaire à moyenne.si.ens , pour calculer l'écart type. En fait , mes donnés sont dans A2:A690 . Mon souhait est de calculer l'écart-type des valeurs <150 et >50..

Je préfère pas les matricelles; sauf si pas d'autres solution.
Merci.


3 réponses

Messages postés
52538
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
14 413
Bonjour,

Tu disposes de plusieurs fonctions ECARTYPE dans Excel.
Pourquoi nous le demander ?
Et sans fichier joint, de toutes façons on ne peut pas te fournir de solution concrète ...
 1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (8192 Ko maxi)
3) Tu défiles vers le bas pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".
=>Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016

Bonjour,
je cherche une fonction d'écart-type similaire à moyenne.si.ens
Merci quand même.
Messages postés
18
Date d'inscription
samedi 2 avril 2016
Statut
Membre
Dernière intervention
26 avril 2016
3
Bonjour,

je contournerai le problème en ajoutant deux colonnes.

Dans la première (la B) j'isole les valeurs supérieures à 150
=SI(A1>150;A1;"")
Dans la deuxième (la C) j'isole les valeurs inférieures à 50
=SI(A1<50;A1;"")

Ensuite tu applique ta fonction ECARTYPE sur ces deux colonnes.

Bonne journée !
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016

Merci , Franchy71 pour ta réponse. Je ne souhaite pas multiplier les colonnes de mon chiffrier.
Messages postés
23601
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
6 430
Bonjour,

tu peux aussi utiliser Agregat() sur une plage filtrée.
eric
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016

Merci Eric, En absence d'une fonction Excel, Agregat m'a permis de contourner le problème.
Messages postés
23601
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 octobre 2020
6 430
=ECARTYPE(SI((A2:A22>50)*(A2:A22<150);A2:A22;""))
en matricielle a l'air de passer, à contrôler.
Valider avec Shift+Ctrl+Entrée
Messages postés
8
Date d'inscription
dimanche 27 mars 2016
Statut
Membre
Dernière intervention
3 avril 2016

Oui, bien. MERCI.