Remplir cellule sous condition

[Résolu/Fermé]
Signaler
-
Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
-
Bonjour, j' ai un sous excel

3 colonnes "TRAITES" "CAMPAGNES" "DATE DE LIVRAISON"
-la colonne "DATE DE LIVRAISON" contient déjà des dates (au format 01/01/2000)
je dois remplir la colonne TRAITES en fonction du mois de la "DATE DE LIVRAISON"
- si la période est comprise entre Avril et Septembre inclus alors mettre "Petite Traite" dans la cellule de la colonne "TRAITES" correspondant sinon mettre "Grande Traite".

et ensuite remplir la colonne CAMPAGNES en fonction de l’année de la "DATE DE LIVRAISON"
-si l’année est 2012 mettre "11/12" ou si 2013 mettre "12/13" ou si 2014 mettre "13/14" ou si 2015 mettre "14/15" ou si 2016 mettre "15/16" sinon ne rien mettre.

Merci de me répondre !!!

3 réponses

Messages postés
5639
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
22 septembre 2021
650
Bonjour Yann2016

Pour exemple les données sont en ligne 2 colonne A à C

en A2 mettre cette formule

=SI(ET(MOIS(C2)>3;MOIS(C2)<10);"Petite traite";"Grande

en B2 celle-ci

=DROITE(ANNEE(C2);2)-1&"/"&DROITE(ANNEE(C2);2)
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 058
Bonjour
on commence en ligne 2 avec TRAITE en colonne A etc.. à adapter si besoin
la colonne date est donc C
en A2:
=SI(C2="";"";SI(ET(MOIS(C2)>3;MOIS(C2)<10);"petite traite";"grande traite"))

en B2
=SI(C2="";"";DROITE(ANNEE(C2);2)-1&"/"&DROITE(ANNEE(C2);2))

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221
colonne A=traites, B=campagne c= date

pour campagne
=si C="";"";ANNEE(C2)-1&"/"&ANNEE(C2))
pour traite
=si(C2="";"";si((MOIS(C2)>=4)*(MOIS(C2)<=9);"petite";"grande"))
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 058
Salut Michel Ca va?

.... et merci pour lui :-)) :-)) :-))

bien amicalement
Messages postés
16513
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
17 septembre 2021
3 221 >
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021

salut Vaucluse,

ca va comme un jeune homme (ou presque)

j'avais oublié le (droite,....;2)

j'avais annulé mon message voyant le tien mais j'ai pas dû appuyer sur le bouton !!!