Possibilité de saisir son texte sur une formule [Résolu/Fermé]

Signaler
-
 Jidocdo -
Bonjour à tous,

Je souhaitais savoir s'il était possible de saisir du texte sur une cellule contenant déjà une formule. Je détaille mon cas : (exemple simplifié)

Feuille 1
Colon. 1-----Colon. 2
email 1---- date1
email 2---- date 2

Feuille 2 :
Colon.1-----Colon. 2
email 2---- date 2

Je souhaite remplir la colonne 2 de la feuille 1. Je veux effectuer un vlookup dans la feuille 2 et si l'email existe dans cette feuille, copier la date correspondante. MAIS si il n'existe pas, je voudrais pouvoir rentrer la date manuellement.

Est il possible de réaliser cela ?
Voila la formule que j'ai en tête :)
=if(isna(vlookup(email1....), [Taper ici la date manuellement] , vlookup(email....))

Merci

2 réponses

Messages postés
575
Date d'inscription
vendredi 11 juillet 2014
Statut
Membre
Dernière intervention
30 mars 2016
14
Bonjour,

Si vous êtes sur Excel en Français, votre formule devra composer avec les fonctions TEXTE(...,"jj/mm/aaaa"), SIERREUR() et RECHERCHEV().

Dans votre cas colonne B:B de la feuille 1 (à dérouler à partir de B1):
=TEXTE(SIERREUR(RECHERCHEV(Feuil1!A1;Feuil2!A:B;2;FAUX);"Taper ici la date manuellement");"jj/mm/aaaa")

Cdt,
Messages postés
25160
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 344
Bonjour
vous allez supprimer obligatoirement la formule si vous entrez un texte manuellement

le plus sur serait de prévoir une colonne pour les dates non trouvées:
avec B la formule

=SIERREUR(RECHERCHEV(A1;Feuil1!$A:$B;2;0);C1)
qui vous permettra de renvoyez en B la date entrée manuellement en C

et au moins, si un jour ou l'autre, ce mail entre en feuil1 avec les infos, tout sera rectifié

pour des questions de présentation vous pouvez placer une mise en forme sur C qui affiche une police de la même couleur que le fond pour ne pas voir deux fois la date.

Vous pouvez aussi "signaler" par une mise en forme conditionnelle les valeurs de A feuil2 non présentes en feuil1
crdlmnt

nommez le champ A de feuil 1
en feuil2 formatez la colonne A e MFC conditionnielle avec cette formule:

=NB.SI(nom du cham feuil1AX:Ay;A1)=0

crdlmnt


Merci pour vos réponses.

Bonne soirée