Fonction à 2 arguments...

Résolu/Fermé
michel91
Messages postés
184
Date d'inscription
dimanche 4 février 2007
Statut
Membre
Dernière intervention
24 février 2020
- 13 mars 2016 à 17:47
Raymond PENTIER
Messages postés
56108
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 mai 2022
- 13 mars 2016 à 19:14
Bonjour,

En B1, j'ai la fonction =si(A1>10;"alerte";si(A1<5;"commande";""))

En tapant cette fonction le mot "commande" apparait dans toute ma colonne B.

Je voudrais que "commande" n'apparaisse pas tout le temps mais n'apparaisse que si A1 est inférieur à 5 ou A2 est inférieur à 5 etc...

Merci


2 réponses

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 256
Modifié par Vaucluse le 13/03/2016 à 17:56
Bonjour

êtes vous sur de ce que avez écrit ci dessus:
alerte si A1>10 ?????

ça manque de logique

si, en fait c'est < que vous utilisez, il faut construire la formule dans l'autre sens, car sinon Excel prend par exemple 4 comme plus petit que 10 et ne cherche pas plus loin.:


=SI(A1<5;"commande";SI(A1<10;"alerte";"")

et pour éviter d'avoir un résultat quand A est vide

==SI(A1="";"";SI(A1<5;"commande";SI(A1<10;"alerte";"")))

crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
0
michel91
Messages postés
184
Date d'inscription
dimanche 4 février 2007
Statut
Membre
Dernière intervention
24 février 2020
46
13 mars 2016 à 18:22
Merci, j'ai bien écrit A1>10, ça parait bizarre mais c'est normal.

Effectivement, j'ai commencé ma fonction dans le mauvais sens.

Merci encore.
0
Raymond PENTIER
Messages postés
56108
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
25 mai 2022
17 209
13 mars 2016 à 19:14
Bonjour michel91

à mon avis ta formule est bonne ; il suffit que tu saisisses une valeur dans A pour t'en rendre compte ; tant que A est vide, A1 vaut 0, donc est <5, et il est normal que "Commande" s'affiche.

Si tu veux l'éviter, suis les conseils de mon ami Vaucluse et saisis
=SI(A1="";"";SI(A1>10;"alerte";SI(A1<5;"commande";"")))
0