/tmp espace limité ? [Résolu/Fermé]

Signaler
-
Messages postés
35392
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
15 août 2020
-
Bonjour,
Je suis sous Fedora 23 et j'essaye d'installer un logiciel qui me demande beaucoup d'espace dans /tmp.
Or celui-ci me signale qu'il n'a pas assez de place dans ce répertoire (il demande 300 Mo).
Lors de mon partitionnement, j'ai seulement créé un /, un /boot et la swap, le /tmp n'est donc pas sur une partition isolée : je ne vois pas pourquoi sa taille serait limitée ?

Merci pour votre aide.

1 réponse

Messages postés
35392
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
15 août 2020
5 335
Salut,

Et combien il reste sur ta racine ?
df -hT | grep ^/dev 

Messages postés
6
Date d'inscription
mardi 8 mars 2016
Statut
Membre
Dernière intervention
8 mars 2016

[root@oracleim weblogic]# cat /etc/fstab 

#
# /etc/fstab
# Created by anaconda on Tue Mar 8 16:08:21 2016
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
UUID=7ff701ee-ab88-4031-a981-e9facd212dcf / ext4 defaults 1 1
UUID=81ca411f-7e05-4acd-94b5-2d9c5a4b3a10 swap swap defaults 0 0
Messages postés
35392
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
15 août 2020
5 335 >
Messages postés
6
Date d'inscription
mardi 8 mars 2016
Statut
Membre
Dernière intervention
8 mars 2016

Tiré du lien donné plus haut :

 Release Notes

/tmp now defaults to tmpfs. This might break a few programs which assume that they can place large files in /tmp or that /tmp is persistant across boot. If these programs cannot be fixed to use /var/tmp instead of /tmp for this, there are two options to undo the /tmp-on-tmpfs change locally:

Disable mounting of tmpfs on /tmp by issuing "systemctl mask tmp.mount", and reboot. Note that this will entirely disable any mounting of any file system to /tmp. /tmp will hence reside on the root fs if this is done. (Undo with "systemctl unmask tmp.mount")

To mount a different file system (instead of tmpfs) to this place simply edit /etc/fstab, and add an entry for it there, it will take precedence over our new distro default. Also, reboot.
Messages postés
6
Date d'inscription
mardi 8 mars 2016
Statut
Membre
Dernière intervention
8 mars 2016
>
Messages postés
35392
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
15 août 2020

Merci :-)
... Ou alors changer de distrib parce que décidément j'ai que des problèmes avec celle-ci ^^
Messages postés
6
Date d'inscription
mardi 8 mars 2016
Statut
Membre
Dernière intervention
8 mars 2016

Bon, j'ai donc fait un "systemctl mask tmp.mount" comme indiqué, puis rebooté la machine. La VM n'a pas rebooté, je ne sais pas pourquoi donc je l'ai killée puis redémarré via Virtualbox. Elle a bien redémarré, j'ai voulu réinstaller mon programme et cette fois il semble que tout va bien :
Vérification de l'espace temporaire : il doit être supérieur à 300 Mo.   Réel 77192 Mo    Succès

Donc rendez-vous au prochain épisode, merci pour ton aide en tout cas !
Messages postés
35392
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
15 août 2020
5 335 >
Messages postés
6
Date d'inscription
mardi 8 mars 2016
Statut
Membre
Dernière intervention
8 mars 2016

Happy for you.

De rien ;-)