Fonction SI avec ET OU dans une plage horaires [Résolu/Fermé]

Signaler
-
 ZIZA -
Bonjour,

Je m'arrache les cheveux depuis 2 semaines .... il est temps de demander de l'aide !HELP!!

j'ai 2 tableaux dans un fichier
le premier onglet dans lequel j'ai des noms colonne à côté un horaire
le deuxième onglet j'ai créé des plages horaire
et je souhaite que les horaires trouvé dans le premier onglet vienne en nombre se cumuler sur les lignes correspondantes de la plage horaire du deuxième onglet


Lien pour le fichier
http://dl.free.fr/fiJednk6I

Le lien a été crée : http://www.cjoint.com/c/FABrtNM4JhW

2 réponses

Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Bonsoir
déposez votre fichier ici:
https://www.cjoint.com/
ça évitera de se fader la pub avant de charger
à vous lire
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

c'est fait ! merci pour l'info

Le lien a été crée : http://www.cjoint.com/c/FABrtNM4JhW
Messages postés
25767
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 janvier 2021
5 734
Pas tout compris, mais voyez si cette formule répond à votre demande
=SOMME.SI.ENS('details mensuel'!B:B;'details mensuel'!B:B;">"&A8;'details mensuel'!B:B;">="&B8)

et pour le nombre dans la plage

=NB.SI.ENS('details mensuel'!B:B;">"&A8;'details mensuel'!B:B;">="&B8)

utilisable avec Excel à partir de 2007, sinon:

=SOMMEPROD(('details mensuel'!$B$3:$B$30>A8)*('details mensuel'!$B$3:$B$30<=B8)*('details mensuel'!$B$3:$B$30))
et pour le nombre

=SOMMEPROD(('details mensuel'!$B$3:$B$30>A8)*('details mensuel'!$B$3:$B$30<=B8))

dans les deux cas, le nombre dans une cellule "standard"


et revenez avec plus d'info si ça n'est pas ça

crdlmnt

La qualité de la réponse dépend surtout de la clarté de la question, merci!
YES !!! Trop fort

Il s'agit d'interventions terrain et ce que je voulais c'était pouvoir avoir le nombre d'interventions par tranche horaire !!

Là j'ai envoyé une extraction, mais le tableau réel comporte 114 lignes et il y a un onglet par mois.
INUTILE DE PRECISER QUE CETTE FORMULE VA ME FACILITER LA TACHE !!

=SOMMEPROD(('details mensuel'!$B$3:$B$30>A8)*('details mensuel'!$B$3:$B$30<=B8))

Merci beaucoup Vaucluse
et bonne soirée