Somme conditionnelle [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mardi 12 janvier 2016
Statut
Membre
Dernière intervention
12 janvier 2016
-
Messages postés
3
Date d'inscription
mardi 12 janvier 2016
Statut
Membre
Dernière intervention
12 janvier 2016
-
Bonjour,
J'aurai besoin de vos lumières
Je souhaite additionner uniquement l'ETIQ="XCAP1" pour la période uniquement de SEPT et OCT 2015 et faire le total des HEURES correspondant uniquement à ces 2 critères.
Merci de votre aide
Michel

A B C
ETIQ HEURES MOIS
XCAP1 1675,66 sept-15
XCAP2 387 sept-15
XBPA 1344 sept-15
XCAP1 2445 oct-15
XCAP2 2610 oct-15
XBPA 2398 oct-15
XCAP1 10000 août-15

1 réponse

Messages postés
5550
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
21 avril 2021
595
Bonjour

Sous EXCEL2010 Avec la fonction SOMME.SI.ENS

=SOMME.SI.ENS($B$2:$B$8;$A$2:$A$8;E1;$C$2:$C$8;F1)

OU E1 = XCAP1
F1 = OCT-15
Messages postés
3
Date d'inscription
mardi 12 janvier 2016
Statut
Membre
Dernière intervention
12 janvier 2016

Merci philos
Si en F1 ce n'est pas un mois mais en F1 et F2 une borne de date : septembre et novembre
Quelle serait votre formule ?
Encore merci d'avance
Michel
Messages postés
25985
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2021
5 885
Pour avoir la somme des mois entre les deux limites, il faut que F1 et F2 soit les N° des mois à prendre en compte. La formule ci dessous pourrait alors convenir

=SOMMEPROD((A2:A8=E1)*(MOIS(C2:C8)>=F1)*MOIS(C2:C8)<=F2)*(B2:B8))

ou alors avec F1 1° jour limite et F2 dernier jour limite (date format Excel)

=SOMME.SI.ENS(B2:B8;A2:A8;E1;C2:C8;">="&F1;C2:C8;"<="&F2)

crdlmnt
Messages postés
3
Date d'inscription
mardi 12 janvier 2016
Statut
Membre
Dernière intervention
12 janvier 2016
>
Messages postés
25985
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 avril 2021

Merci de votre aide