Formule comprise entre 2 valeurs

[Fermé]
Signaler
-
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
-
Bonjour,

Je voudrais remplacer le résultat de E9-D9 par 0 si ce résultat est compris entre -0.042 et 0.042. Si non je voudrais indiquer le résultat de ce calcul.

Voila la solution que j'ai trouvé

=SI(E9-D9<0.042,SI(E9-D9>-0.042,0,E9-D9),E9-D9)

Ma solution fonctionne bien sauf pour les resultats de 0.042 et -0.042 qui sont aussi remplacés par 0 alors aue je voudrais les indiquer.

Merci d'avance pour votre aide.

1 réponse

Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bonjour,

Les inégalités larges sont à écrire <= et >=
Sinon, tu peux faire :
=SI(ABS(E9-D9)<=0,42;0;E9-D9)

A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
=SI(ABS(E9-D9)<0,42;0;E9-D9)

Mais dans E9 et D9 tu dois avoir des arrondis.
>
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021

J'ai essayé d'enlever l' = aussi mais ca n'a pas reussi,, car E9 et D9 ne sont pas des arrondis. Y a t-il une solution si E9 et D9 sont des chiffres à virgules??
Ca me fatigue vraiment

Merci
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Fournir ton fichier via https://www.cjoint.com/
>
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021

http://www.cjoint.com/c/EKqrv7A0STW

Merci zoul je t ai mis une fleche sur la formule que je travaille
Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bon,
Tu es tombé sur une faille de l'informatique... (conversion décimal --> binaire : https://forums.commentcamarche.net/forum/affich-26806700-erreur-de-decimale-sur-somme-excel#7 )
Avec en E9 : 7,042 et en D9 : 7, tente en F9 : E9-D9-0,042 ; chez moi, je ne tombe pas sur 0 mais sur quelque chose qui est proche de 10^-16
Maintenant essaie :
=(ARRONDI(E9-D9;3)=R11)
ou
=(1000*E9-1000*D9=1000*R11).

Donc dans tes formules je ne vois pas mieux que d'utiliser des entiers en multipliant par 1000 ou d'utiliser l'arrondi à la 3è décimale.

A+