Moyenne Générale coefficientée

Fermé
Signaler
Messages postés
24
Date d'inscription
dimanche 8 juin 2014
Statut
Membre
Dernière intervention
4 août 2016
-
Messages postés
13345
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 janvier 2022
-
Bonjour,

Je suis à l'université et je suis en train de faire un tableur excel pour calculer la moyenne générale de toutes mes notes. ça, je sais faire !

Mais le problème, c'est que je n'ai pas encore de notes dans certaines matières, il y a donc des cases vides...

En conséquence, la moyenne ne se calcule pas et donne cette réponse " DIV/0!"

Comment faire donc, pour calculer une moyenne générale coefficientée qui comporte des cases vides ?

Merci d'avance pour vos réponse !

1 réponse

Messages postés
13345
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
20 janvier 2022
2 325
Bonjour

Avec les coef dans la plage B3:F3 et les notes dans la plage B4:F4 :
=SOMMEPROD((B3:F3)*(B4:F4))/SOMME.SI(B4:F4;">0";B3:F3)

Cdlmnt
Via
0