Impossible Trier

Résolu/Fermé
Viking58 Messages postés 186 Date d'inscription vendredi 5 décembre 2014 Statut Membre Dernière intervention 5 janvier 2018 - 25 août 2015 à 17:31
Viking58 Messages postés 186 Date d'inscription vendredi 5 décembre 2014 Statut Membre Dernière intervention 5 janvier 2018 - 26 août 2015 à 13:54
Bonjour.

Le un des problèmes les plus ardus qu'il m'est été donné de rencontrer sur Excel:

Je veux trier par ordre chronologique les dates de la cellule B.
Ayant des dates d'avant 1900 dans la colonne A, J'ai appliqué la formule suivante que l'on m'avait donné, à toute cette colonne.
=SI(ESTNUM(A1520);DATE(ANNEE(A1520)+1000;MOIS(A1520);JOUR(A1520));(GAUCHE(A1520;2) & STXT(A1520;3;NBCAR(A1520)-7) & CNUM(DROITE(A1520;4))+1000)*1)

Ce qui me permet d'obtenir en colonne B une date 'triable"

Hors, quand je veux trier, Excel me renvoie le message:




J'ai perdu beaucoup d'heures hier à essayer de trouver une réponse, lu des tonnes de posts, sans résultat.

Mes cellules ne sont pas fusionnées
Leur taille est identique puisque j'ai donné la Hauteur de ligne sur tout le tableau
à sa création.




A voir également:

6 réponses

Frenchie83 Messages postés 2240 Date d'inscription lundi 6 mai 2013 Statut Membre Dernière intervention 11 août 2023 336
25 août 2015 à 18:26
Bonjour
Excel n'invente rien.
N'auriez-vous pas pour une question de lisibilité fusionner les cellules A1 et B1 pour n'en faire qu'une et la nommer "Date" à tout hasard?
0
Viking58 Messages postés 186 Date d'inscription vendredi 5 décembre 2014 Statut Membre Dernière intervention 5 janvier 2018 7
25 août 2015 à 18:40
Non, Frenchie83.
La colonne A est au format date "mardi 25 août 2015 "
La colonne B est au format date "25/08/3015"
Elles ne sont donc non fusionnées.
0