Conditions SI dans graphique excel affichage de valeur ou texte

Résolu/Fermé
vertig56
Messages postés
5
Date d'inscription
jeudi 21 mai 2015
Statut
Membre
Dernière intervention
22 mai 2015
- 21 mai 2015 à 19:54
vertig56
Messages postés
5
Date d'inscription
jeudi 21 mai 2015
Statut
Membre
Dernière intervention
22 mai 2015
- 22 mai 2015 à 18:44
Bonjour,

Je me demande s'il est possible de mettre une fonction SI dans un graphique Excel 2010 ?

Je souhaite indiquer un texte si la valeur est à zéro.

Je fais un graphique qui contient du temps, il y a le temps maximal à utiliser et le temps utilisé. Quand le temps utilisé arrive ou dépasse la valeur du temps maximal, le compteur affiche 00:00.

J'aimerais pouvoir remplacer ce 00:00 par un texte du type temps épuisé !


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
J'ai choisi un graphique camembert pour afficher. Je pense que c'est plus clair pour tout le monde ainsi, quand pensez-vous?

Le mieux serait d'avoir l'affichage du temps dépassé, mais je pense que j'en demande trop là ! :-)

Et l'affichage risque d'être trop compliqué !?

Qu'en pensez-vous ? C'est possible ?

1 réponse

via55
Messages postés
13598
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 mai 2022
2 401
21 mai 2015 à 21:09
Bonsoir

Non je ne pense que ce soit possible mais on peut :
-cacher le 00:00 disgracieux
- afficher les temps utilisée et restant sur un 1/2 camembert et le dépassement sur l'autre 1/2
Exemple : https://www.cjoint.com/?0EvvfuROyOB

Cdlmnt
Via
1
vertig56
Messages postés
5
Date d'inscription
jeudi 21 mai 2015
Statut
Membre
Dernière intervention
22 mai 2015

22 mai 2015 à 10:20
C'est sympa vu comme ça !

Merci Via, moi ça me va bien.

Super ! Merci.
0
tontong
Messages postés
2512
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
17 mai 2022
1 023
22 mai 2015 à 11:53
Bonjour,
Pour masquer les zéros on peut aussi adopter pour les étiquettes de données un format de Nombre Personnalisé: hh:mm;; ou hh:mm;;"dépassé"
0
vertig56
Messages postés
5
Date d'inscription
jeudi 21 mai 2015
Statut
Membre
Dernière intervention
22 mai 2015

22 mai 2015 à 16:06
Bonjour,
Merci tontong pour l'astuce du format de Nombre Personnalisé: hh:mm;; ou hh:mm;;"dépassé"
J'ai opté pour : hh:mm; ou hh:mm;""

Par contre, j'ai un souci avec la variable du "Temps acheté" que j'ai oublié de mentionner.
Voici mon test : https://www.cjoint.com/c/EEwqbiqxiej

Je ne comprends pas le calcul de la cellule du temps imparti utilisé (=SI(G10>2,5/24;2,5/24;G10)) - Je ne peux pas remplacer la valeur 2.5 par le résultat d'une cellule !
0
via55
Messages postés
13598
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 mai 2022
2 401 > vertig56
Messages postés
5
Date d'inscription
jeudi 21 mai 2015
Statut
Membre
Dernière intervention
22 mai 2015

22 mai 2015 à 17:29
Bonjour,

Pour les formules j'étais parti de ton exemple avec 2:30 d'où les 2,5
Fichier avec formules rectifiées pour s'adapter aux changements de D7
https://www.cjoint.com/?0Ewrzxp7pkv

Cdlmnt
Via
0
tontong
Messages postés
2512
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
17 mai 2022
1 023
22 mai 2015 à 17:26
La formule sera seulement adaptée au contenu de la cellule.
1- si F2 contient 2,5 (un nombre d'heures décimal) =SI(G10>$F$2/24;$F$2/24;G10)
2- si F2 contient 02:30:00 (un nombre d'heures au format d'heure Excel)
=SI(B2>$F$2;$F$2;B2)
parce que la seule unité de temps Excel est le jour (24h).
0