Boutons VBA qui deviennent invisibles [Résolu/Fermé]

Signaler
Messages postés
182
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
8 juillet 2020
-
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
-
Bonjour à toutes et à tous
J'ai Excel 2013.
Quand j'ouvre mon fichier Excel que j'ai développé sur Excel 2013 et prenant en charges des macros, je ne trouve plus quelques boutons de commande aussi des Zones combinées, ils sont sur le ficher mais invisibles, j'ai trouvé une astuce pour les faire apparaitre, c'est faire un aperçus avant l'impression puis retour au normal et les boutons sont là, mais cette astuce est douloureuse. Ou se situe le problème ? Merci pour vos aides
Cordialement

3 réponses

Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 073
Bonjour,
Vous explications ne nous aide pas du tout....
Si vous avez-vous une macro qui se déclenche à l0ouverture du classeur, alors contrôler qu'il n'y a pas un code qui rend invisible des objets ?

Messages postés
182
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
8 juillet 2020
3
Bonjour,
Merci bien Pingou
Je crois que le problème est dans MO 2013 que j'ai installé, car mon fichier marche très avec la version 2010
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 073
Bonjour,
Dans ce cas vous réinstallez MSO 2013.
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
6 365
Bonjour,

Sur MO2013 si tu ajoutes un bouton ActiveX dans un classeur neuf, il porte quel numéro ? 21 ?
eric
Messages postés
182
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
8 juillet 2020
3
Bonjour,
Non c'est le 1
En plus j'ai pas pu ajouter d'autres contrôles supplémentaires (vba)
la fenêtre des contrôles ne s'affiche plus.
Donc je vais réinstaller MSO 2013 et on vira.
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 073
Bonsoir eriiic,
Je suis curieux de savoir le pourquoi de ta question ajoutes.... !
Amicales salutations.
Le Pingou
Messages postés
23504
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
26 septembre 2020
6 365
Salut le pingou,

Pour savoir s'il avait des pb avec la maj de sécurité du 09/12 qui bousille les activeX.
Cet effet là n'était pas encore constaté mais qui sait :-)
eric
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 073
Merci eriiic c'est parfait.
Amicales salutations.
Le Pingou