Dans une plage, renvoi la valeur C3 si condition C1 et C2

[Résolu/Fermé]
Signaler
-
 Joe -
Bonjour,

Je souhaite résoudre un problème concernant la recherche d'informations dans une plage de cellule.

Mon fichier contient :
Feuille1 : Noms et prénoms + autres infos
Feuille 2 : Noms et prénoms + villes

je cherche donc à afficher les villes correspondantes aux personnes de la feuille 2 vers la feuille 1. Je n'ai eu aucun souci dans la plupart des cas par un INDEX + EQUIV en me référent aux Noms des personnes. Mon souci intervient dans les homonymes :

Exemple : Si Feuille 2 contient Dupont - Paul - Paris
et Dupont - Rémi - Marseille

Je n'arrive pas à retrouver Marseille pour Dupont - Rémi car mon index equiv se réfère aux noms (il me renvoie donc Paris). Je cherchai à poser des conditions sur mon equiv pour que si des doublons apparaissent au niveaux des noms, ma formule cherche également le prénom pour renvoyer un equiv correspondant à la ligne de la bonne personne.

Merci d'avance de votre aide

1 réponse

Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Bonjour

une formule matricielle qui tient compte à la fois du nom et du prénom (qui fonctionne indifféremment pour les noms avec ou sans doublon)
feuil2: nom en A / Prénom en B / valeur à ressortir en C
feuil1 (édition): nom en A prénom en B
en C1 cette formule:
=INDEX(feuil2!C:C;EQUIV(A1&B1;feuil1!A:A&feuil1!B:B;0))
formule matricielle à rentrer avec la touche enter en maintenant les touches ctrl et shift enfoncées
Elle se retrouve automatiquement entre accolades dans la barre de formule
vous pouvez la compléter pour éviter les affichages d'erreur si A ou B sont vides:

=SIERREUR(INDEX(feuil2!C:C;EQUIV(A1&B1;feuil1!A:A&feuil1!B:B;0));"")

valable à partir de Excel 2007 seulement
crdlmnt


Errare humanum est, perseverare diabolicum
Ca marche du tonnerre merci beaucoup !!