Valeur inférieur la plus proche [Fermé]

Signaler
-
Messages postés
23507
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
-
Bonjour,
sous excel j'ai un tableau de valeurs en vba, et je souhaite comparé une valeur à ce tableau et qu'il me retourne la valeur inférieur la plus proche que celui-ci contient.
merci, cdlt.

3 réponses

Messages postés
9572
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
28 septembre 2020
1 910
Bonjour

Pas très claire ta demande. Une tentative quand même https://www.cjoint.com/?3DqsEOhTJSE

cdlmnt

Cdlmnt
Messages postés
17232
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 septembre 2020
4 262
Bonsoir,
effectivement pas très clair "sous excel j'ai un tableau de valeurs en vba" que faut il comprendre !

tu peux y arriver par formule matricielle, exemple pour la plage A2:A30 et valeur rechercher en C2
=INDEX(A2:A30;EQUIV(MIN(ABS(C2-A2:A30));ABS(C2-A2:A30);0))
avec plage nommée exemple List, la formule devient
=INDEX(List;EQUIV(MIN(ABS(C2-List));ABS(C2-List);0))

ou toujours en formule matricelle pour la valeur inférieure
=MAX(SI(A2:A30<=D2;A2:A30))A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
23507
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
6 374
Bonjour à tous,

et si tes nombre sont triés :
=RECHERCHEV(3;A2:A30;1)
3 étant la valeur cherchée

eric