Jeux d'icones avec la fonction SI [Résolu/Fermé]

Signaler
Messages postés
6
Date d'inscription
mercredi 8 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
-
Messages postés
25654
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
-
Bonjour

Je débute sur Excel et découvre les nombreuses possibilités mais malgré cela je n'arrive à obtenir ce que je souhaite.
Je voudrai afficher en fonction du résultat : gagné, perdu, en cours... un icône vert, rouge...
Les icônes ne s'utilisent qu'avec des données numérique j'ai alors pensé à la fonction SI que je ne maîtrise pas très bien. Si Gagné, afficher 1, si en cours afficher 2... puis mettre en forme par la suite avec les jeux d'icônes.

Merci de votre aide

1 réponse

Messages postés
25654
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
5 642
Bonjour
=SI(A1="Gagné";1;SI(A1="Perdu";2;... ect )))
et fermez avec autant de parenthèses que de SI

... mais vous pouvez afficher directement un Widget dans la cellule B1 avec une MFC par formule
formatez B1 en police Wingding et placer la formule:
=SI(A1="Gagné";"J";SI(A1="Perdu";"L";"K"))
et voyez le résulktat
vous pouvez associer à cette cellule une MFC par formule:
=B1="J" > format vert
=B1="L" > format roige
ce n'est qu'un exemple, vous pouvez voir les caractères et leur format de police en sélectionnant B1 / Ruban / Insertion/ Symbole et insérer




crdlmnt

Errare humanum est, perseverare diabolicum
Merci beaucoup Vaucluse, j'avais un soucis de parenthèse dans ma formule. J'ai opté pour les smileys Wingding
Messages postés
25654
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
3 décembre 2020
5 642
OK alors on passe ça en résolu
Bonne route
crdlmnt