Calcul effectif annuel [Fermé]

Signaler
-
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
-
Bonjour,

Actuellement je cherche un outil sous Excel pour calculer l'effectif annuel d'employés de 2004 à ce jour, à noter que j'ai la date d'entrée et la date de départ pour chaque employé.

Merci beaucoup

1 réponse

Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Bonjour
la date d'entrée en A
la date de sortie en B
l'année en C à partir de C1 avec 2004 en C1
la formule (à partir d'excel 2007)


=NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;">="&DATE(C1;1;1))

et pour compter les présents au cas où ils n'aient pas de date de sorties:

=NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;">="&DATE(C1;1;1))+NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;"")

fonctionne aussi avec:
=SOMMEPROD((A1:A100<=DATE(C1;12;13))*(A1:A100>0)*((B1:B100>=DATE(C1;1;1))+(B1:B100="")))

pour un tableau de 1 à 100 (dans ce cas N° de lignes obligatoires)

Crdlmnt


Errare humanum est, perseverare diabolicum
>
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020

Merci beaucoup.
Messages postés
23558
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020
6 404
Bonjour,

il serait bon que tu donnes ta définition d'un effectif annuel.
Au 01/01 ?
Au 31/12 ?
Au proratat de la présence ? Présent 4 mois =>0.33
eric
>
Messages postés
23558
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
12 octobre 2020

Bonjour, merci beaucoup de votre aide, j'aimerais avoir l'effectif au 31/12 de chaque année.

Crdlmnt
Pour l'année 2015 notre effectif est de 38 dont 2 entrées pour l'année 2015 mais pas 41 comme dans le fichier que vous avez présenté
Messages postés
25375
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2020
5 525
Ah, z'êtes sur?
dans le fichier, de ligne 2 à 74 je compte 41 cellules vides en B ayant une date en A? Quelles sont les trois lignes qui ne devraient pas y être?