Calcul effectif annuel

Fermé
shero - 8 mars 2015 à 18:41
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
- 11 mars 2015 à 11:39
Bonjour,

Actuellement je cherche un outil sous Excel pour calculer l'effectif annuel d'employés de 2004 à ce jour, à noter que j'ai la date d'entrée et la date de départ pour chaque employé.

Merci beaucoup
A voir également:

1 réponse

Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
Modifié par Vaucluse le 8/03/2015 à 19:19
Bonjour
la date d'entrée en A
la date de sortie en B
l'année en C à partir de C1 avec 2004 en C1
la formule (à partir d'excel 2007)


=NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;">="&DATE(C1;1;1))

et pour compter les présents au cas où ils n'aient pas de date de sorties:

=NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;">="&DATE(C1;1;1))+NB.SI.ENS(A:A;"<="&DATE(C1;12;31);B:B;"")

fonctionne aussi avec:
=SOMMEPROD((A1:A100<=DATE(C1;12;13))*(A1:A100>0)*((B1:B100>=DATE(C1;1;1))+(B1:B100="")))

pour un tableau de 1 à 100 (dans ce cas N° de lignes obligatoires)

Crdlmnt


Errare humanum est, perseverare diabolicum
0
Merci pour votre aide, le résultat ne correspond pas à l'effectif que j'ai pour l'année 2014 par exemple, et comment faire pour les personnes qui sont encore dans l'entreprise (date de sortie vide).

Salutations
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
8 mars 2015 à 20:00
Il faudrait avoir votre liste pour pouvoir adapter.
les 2° ou 3° formules devraient faire l'affaire, elle comptent en principe les effectifs entrés avant le 31/12 de l"année choisi et sortis après le 1° janvier de la même année, et ajoute aussi ceux qui n'ont pas de dates de sortie

Sauf une faute de frappe dans la 3° _c'est ma spécialité:
=SOMMEPROD((A1:A100<=DATE(C1;12;31))*(A1:A100>0)*((B1:B100>=DATE(C1;1;1))+(B1:B100="")))
(avec 31 au lieu de 13).
pouvez vous déposer un fichier (avec les dates seulement si confidentialité) sur:
https://www.cjoint.com/
et revenir ici coller le lien donné par le site?
A vous lire
0
shero > Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022

Modifié par shero le 8/03/2015 à 20:24
http://cjoint.com/?3CiuImreG9s
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 253
9 mars 2015 à 07:02
Bonjour
voila ce que ça donne,
si erreur (ce qui est toujours possible) dites moi où, sur quelle ligne et combien doit être le résultat.
Pour info, la colonne D donne le total des présents pas année, la, colonne E les entrées de l'année encore présents aujourd'hui
https://www.cjoint.com/c/ECjhh4ExIv6
crdlmnt
0
shero > Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022

11 mars 2015 à 07:59
Merci beaucoup.
0