Somme de cellules * par 115% si autre cellule ="x"

Résolu/Fermé
Exceldebut Messages postés 4 Date d'inscription dimanche 8 mars 2015 Statut Membre Dernière intervention 9 mars 2015 - Modifié par Exceldebut le 8/03/2015 à 20:44
Exceldebut Messages postés 4 Date d'inscription dimanche 8 mars 2015 Statut Membre Dernière intervention 9 mars 2015 - 9 mars 2015 à 10:51
Bonjour, voila mon problème :
Dans un tableau Numbers (ou Excel) une cellule est la somme de 4 cellules mais, si une autre cellule est cochée ("x "ou Aucune) il faut ajouter 115% à la cellule total.

Cellule F42 = somme de K38+B38+B39+B40

Cellule M44 = menu local 1 seul élément : x et vierge par défaut

Si Cellule M44 = x ----> je dois multiplier F42 par 115% (par exemple, si F42 = 100€ et M44 = "x" alors, M42 devient 115€)
(en fait pour une certaine condition, la somme est majorée de 15%)

Si Cellule M44 = vide (Aucune) ----> pas de changement dans F42

Merci d'avance si vous pouvez aider un retraité qui cherche à s'occuper.
A voir également:

1 réponse

Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 399
8 mars 2015 à 19:49
Bonjour

M44 ne peut pas contenir X et devenir aussi 115!

par contre pour F42


=(K38+B38+B39+B40)*SI(M44="X";1,15;1)

crdlmnt
0
Exceldebut Messages postés 4 Date d'inscription dimanche 8 mars 2015 Statut Membre Dernière intervention 9 mars 2015
Modifié par Exceldebut le 8/03/2015 à 20:45
Bonsoir, effectivement, j'avais fait une faute de frappe dans mon texte, j'ai fait la correction. (par exemple, si F42 = 100€ et M44 = "x" alors, F42 devient 115€)
Merci pour votre répons que j'ai testée sous Numbers mais, cela ne fonctionne pas
Bonne soirée et merci pour votre aide.
0
eriiic Messages postés 24575 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 26 mai 2024 7 219
Modifié par eriiic le 8/03/2015 à 22:48
Bonjour,

cela ne fonctionne pas ne veut rien dire sans fournir l'erreur annoncée.
La proposition de vaucluse ne peut que fonctionner.
Si ton séparateur décimal est le . replace la ,
Si pb déposer un fichier avec la formule sur cjoint.com et coller ici le lien fourni.
eric
0
Exceldebut Messages postés 4 Date d'inscription dimanche 8 mars 2015 Statut Membre Dernière intervention 9 mars 2015
9 mars 2015 à 08:57
Bonjour, Je travail sur un iMac avec Yosemite (10.10.2) Excel 2011 et Numbers 3.5.2
L'erreur ??? un triangle isocèle avec point d'exclamation ! sur Numbers.
Je vais réessayer sur Numbers puis sur Excel avec :
=SOMME(K38+B38+B39+B40)*SI(M44="X";1,15;1)
Merci encore pour votre aide
Je doit m'absenter, je vous informe dès que possible.
0
eriiic Messages postés 24575 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 26 mai 2024 7 219
9 mars 2015 à 10:28
Bonjour,

L'erreur ??? un triangle isocèle avec point d'exclamation ! sur Numbers.
Ce n'est pas forcément une erreur. C'est juste un avertissement.
Cliquer dessus pour lire.
eric
0
Exceldebut Messages postés 4 Date d'inscription dimanche 8 mars 2015 Statut Membre Dernière intervention 9 mars 2015
9 mars 2015 à 10:51
OK, je n'avais jamais remarqué cela, effectivement en cliquant dessus voila ce qui est affiché : "L'opérateur « + » attend un nombre, une date ou une durée, mais la cellule B38 contient une chaîne."
Cela m'a permis de vérifier ma chaîne de données et :
Mon problème est résolu : en fait, la série B38 à B40 est une série avec choix multiple le résultat est dans les cellules D38 à D40 en modifiant la formule comme ceci : =SOMME(K38+D38+D39+D40)*SI(M44="X";1,15;1) tout fonctionne !

Je vous remercie tous pour votre aide et, je signale le sujet comme résolu !
0