Formule pour chercher valeur de gauche à droite et inversement. [Résolu/Fermé]

Signaler
Messages postés
20
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
3 novembre 2015
-
Messages postés
20
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
3 novembre 2015
-
Bonjour,

Malgré mes recherches je n'ai pas trouvé la formule qui me permettrait de réaliser ce que je veux. Voici mon problème : j'ai une liste de prénoms de A1 à A10 et une autre de D1 à D10. Dans la cellule F5 j'écris un prénom et je désirerais que excel m'indique en cellule G5 le prénom sur la même ligne (exemple : avec la formule RECHERCHEV en G5 je tape ROGER en F5 et apparait COLETTE en G5 mais si je tape COLETTE quel est la formule qui permet d'afficher ROGER) En résumé quelle formule permet une recherche indifféremment de gauche à droite et de droite à gauche ( j'ai essayé de solutionner mon problème avec 2 formules imbriquées : recherchev et index equiv mais, comme je ne suis pas un pro cela ne fonctionne pas !)
Je joint un tableau qui, j'espère, sera plus clair !!!
Merci de votre aide !
Cordialement.
https://www.cjoint.com/?0BwtWtEWiSb



3 réponses

Messages postés
2172
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
297
Bonjour
essayez ceci
=SIERREUR(RECHERCHEV(F5;A1:D10;4;0);INDIRECT("A"&EQUIV(F5;D1:D10;0)))
cdlt
Messages postés
20
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
3 novembre 2015

Bonjour Frenchie83,

Tout d'abord merci de t'intéresser à mon problème. J'ai testé ta formule mais le résultat affiché est : #NOM ? Peux-tu voir d'où vient le souci ?

Cordialement.
Messages postés
2172
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
9 novembre 2020
297
Ca fonctionne pourtant bien chez moi
voici le fichier
https://www.cjoint.com/c/EBxj10jvbY5
J'ai refait mon tableau sur un ordi plus récent (le mien date de quelques années !!!) avec EXCEL 2007 et votre formule fonctionne parfaitement !!! Comme j'ai crée mon premier fichier sur une version de EXCEL 2003 peut être est ce la cause de cette erreur. Dans tous les cas merci pour votre précieuse aide !

Cordialement.
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 360
Bonjour,

La fonction SIERREUR n'existe pas sur les versions antérieures à Excel2007, si tu dois utiliser des version antérieures à cette version, soit tu télécharges gratuitement le pack de compatibilité sur ce lien
https://www.commentcamarche.net/download/telecharger-34055375-pack-de-compatibilite-microsoft-office

soit tu utilises l'ancienne syntaxe
=SI(ESTERREUR(RECHERCHEV(F5;A1:D10;4;0));INDIRECT("A"&EQUIV(F5;D1:D10;0));RECHERCHEV(F5;A1:D10;4;0))
Messages postés
20
Date d'inscription
dimanche 12 août 2012
Statut
Membre
Dernière intervention
3 novembre 2015

Bonjour Mike-31,

J'ai refait ma formule avec l'ancienne syntaxe et ça fonctionne super ! Merci pour ton aide ! Merci aussi à Frenchie83 !

Amitiés à tous les deux.