Problème de valeur avec la fonction nb.jours.ouvres. [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
11 février 2015
-
Messages postés
3
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
11 février 2015
-
Bonjour,

Je me lancer à poser ma question, car cette fois-ci je n'arrive pas à trouver de solution.

J'utilise la fonction "nb.jours.ouvrés" pour calculer le nombre de jours entre deux dates en prenant en compte les jours fériés.

Mon soucis c'est que les dates stockées pour les jours fériés sont des formules et non des dates (donc pas une valeur directe). De ce fait, la formule "nb.jours.ouvrés" me renvoie #VALEUR! au lieu du nombre de jours.

Existe-t-il un moyen de récupérer uniquement la date dans un autre cellule ? D'autant plus que les dates se modifient en fonction que le jour férié est pris en compte ou pas.

J'ai essayé le copie/coller avec liaison, la fonction cellule... ça marche pas, cela me renvoie une formule et non la valeur...

Merci de votre aide....

5 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
493
Bonjour,

Étonnant car la formule NB.JOURS.OUVRES renvoie le nombre de jours ouvrés, même si les dates stockées pour les jours fériés le sont au travers de formules et non directement des dates .
Tu devrais joindre un exemple avec https://www.cjoint.com/

A+
Messages postés
3
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
11 février 2015

voici le lien https://www.cjoint.com/c/EBlp2qxRiqM

Dans l'onglet Calendrier Action il y a la les dates de jours fériés (E30 à E51) et les calcusl avec la formule des jours ouvrés se fait dans l'onglet Entrees en colonne F

Merci
Messages postés
25436
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 octobre 2020
5 552
Bonjour
o, ne voit pas très bien à quoi sert le renvoi de D à E, mais en tous cas, le problème viens de la formule en D qui renvoie "", donc un texte, quand C30 n'est pas oui.
Remplacez ce "" par 0 sur toute le champ et ça va fonctionner.
crdlmnt
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
493
La cellule E46 pose problème car elle est vide.

J'ai modifié la formule en D46 pour avoir une valeur numérique :
=SI(C46="oui";0;B46)

Ensuite, j'ai décoché l'option "Afficher un zéro dans les cellules qui ont une valeur nulle" pour ne pas laisser afficher la date correspondant à zéro (0-janv.-00).

https://www.cjoint.com/c/EBlqBmAWVNU

A+
Messages postés
3
Date d'inscription
mercredi 11 février 2015
Statut
Membre
Dernière intervention
11 février 2015

j'ai modifié et ça marche .. vraiment super merci, j'avais pas pensé que mon "" était en cause.

Pour répondre : le renvoie me permettre de sélectionner les jours fériés qui seront travaillés et donc à ne pas les prendre en compte.

Le problème est résolue, encore merci