Compter des cellules avec commençant par 3 nombres et lettre

[Résolu/Fermé]
Signaler
-
 Juju -
Bonjour,
J'ai un Tableau Excel dans lequel j'entre des données dans le format: "123PTNLS", "123NTNLS" ou "KPPPTERS"
J'aimerais compter le nombre de cellule dont les 3 premières données sont des chiffres et la 4ème un "P".
Pouvez-vous m'aider s'il vous plaît?

Merci par avance pour votre Aide!

3 réponses

Messages postés
26189
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 septembre 2021
6 056
Bonjour
peut être avec celle ci

Bonjour
peut être avec:

=SOMMEPROD((ESTNUM(GAUCHE(A1:A100;3)*1)*(STXT(A1:A100;5;1)="P")*(A1:A100<>""))

N° de mignes obligatoire avec ce code dans le slimtes de champs.

crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Merci beaucoup, ça marche parfaitement.
Meilleures salutations
Messages postés
1148
Date d'inscription
lundi 10 mai 2010
Statut
Membre
Dernière intervention
14 mars 2021
124
Bonjour,

essaye ca :

=SOMMEPROD((CNUM(GAUCHE(SelectionneTesCellules;3))<1000)*(DROITE(GAUCHE(SelectionneTesCellules;4);1)="P")*(GAUCHE(SelectionneTesCellules;3)))


Le "SelectionneTesCellules" est la plage où sont stockés tes données du type "133P"
ex :
SOMMEPROD((CNUM(GAUCHE(A1:A3;3))<1000)*(DROITE(GAUCHE(A1:A3;4);1)="P")*(GAUCHE(A1:A3;3)))


Chez moi ça fonctionne :)

Cordialement,

Mesurer la masse de sa connerie permettrait dans connaitre sa gravité ;)
Bonjour,

Merci pour votre réponse.
J'ai en fait mal formulé mon problème.
Voici un exemple de liste:


KoG





KDRIVE

010ZPRSI

KDRIVE

KDRIVE

KDRIVE

002ZPMLS

003ZPCMAY

002ZPMLS

KDRIVE

002ZPMLS

oV

oV

oV

007ZPRGE

014JAMSL

KPTEP



KoG

014JAMSL

KoG

kA

KoG

KoN

021Z4PLS

F

KoG

Krank

KoG



KoN



J'aimerais donc compter le nombre de cellules Avec "P" en 5ème Position et dont les 3 premières positions sont des chiffres. De plus, il s'agit d'un fichier Excel où je ne peux pas utiliser les macros... Il y a aussi des cellules vides...
Ca fait beaucoup de paramètres...

En tout cas, merci déjà pour votre aide et le temps passé sur mon problème...

Cordialement

Juju
Messages postés
13097
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2021
2 246
Bonsoir

Avec un fontion personnalisée, à mettre dans un module de l'éditeur VBA (ALT F11 pour ouvrir l'éditeur, Insertion Module puis copier-coller le code et fermer l'éditeur
Function denomb(plageD As Range, plageF As Range, lettre As String)
d = plageD.Row
f = plageF.Row
c = plageD.Column
For x = d To f
code = Cells(x, c).Value
If IsNumeric(Left(code, 3)) And Mid(code, 4, 1) = lettre Then Total = Total + 1
Next
denomb = Total
End Function


La fonction s'utilise après comme toute fonction excel selon la syntaxe :

=denomb(adresse 1ere cellulle;adresse dernière cellule;la lettre cherchée)

ex denomb(A1;A100;"P")

Cdlmnt