Se servir des résultats d'une liste déroulante

Résolu/Fermé
Signaler
Messages postés
44
Date d'inscription
mercredi 27 juin 2012
Statut
Membre
Dernière intervention
1 septembre 2018
-
Messages postés
44
Date d'inscription
mercredi 27 juin 2012
Statut
Membre
Dernière intervention
1 septembre 2018
-
Bonjour,
J'essaie de trouver sans succès une solution à mon problème.
1. J'ai crée une liste déroulante sans problème dans la feuille 1 dans la colonne A. La table à laquelle elle est liée est dans le feuille 2. disons que la liste compte les valeur Oui, Non, Peut-être.
Tout va bien jusque là.
2. Je voudrais en B1 faire une formule qui dirait par exemple : si A1 =''Oui'';''Élèves'';'Bidon''
En d'autres mots, j'aimerais me servir de la valeur de la liste déroulantes comme élément de mon opération SI.

Le problème c'est que, fait directement, Excel ne semble pas lire la valeur qui provient de la liste déroulante.

Est-ce que quelqu'un aurait une solution SVP ?

Merci!

2 réponses

Messages postés
13223
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
6 décembre 2021
2 293
Bonsoir

Si Excel "lit" parfaitement le choix de la liste, encore faut il que les termes soient identiques dans la liste et dans la formule pour que la comparaison donne Vrai (même orthographe, pas d'espace après le mot dans un et pas dans l'autre ..)

Ensuite si tu as plusieurs choix dans la liste il te faudra imbriquer les SI :

=SI(A1="oui";valeur à renvoyer si oui;Si(A1="non";valeur à renvoyer si non;Si(A1="peut-être";valeur à renvoyer si peut-être;valeur à renvoyer si aucun des cas)))

Cdlmnt
Messages postés
44
Date d'inscription
mercredi 27 juin 2012
Statut
Membre
Dernière intervention
1 septembre 2018

Aaaah!! Mince! J'avais un espace de trop dans mes formats. Je m'excuse. Merci d'avoir pris le temps de répondre!!