Erreur the following features not present on the CPU : pae

[Résolu/Fermé]
Signaler
Messages postés
3
Date d'inscription
dimanche 25 janvier 2015
Statut
Membre
Dernière intervention
26 janvier 2015
-
Messages postés
3
Date d'inscription
dimanche 25 janvier 2015
Statut
Membre
Dernière intervention
26 janvier 2015
-
Bonjour,

Je veux installer ubuntu sur mon ordi portable, j'ai essaye avec les version 14.04 et 13.04 et j'ai la même erreur.
J'ai donc grave l'image iso sur dvd, je boot sur le dvd, j'ai la première image d'installation qui s'affiche puis ensuite l'erreur suivante :
This kernel requires the following features not present on the CPU : pae
Unable to boot - please use a kernel appropriate for your CPU.

Quelqu'un à une petite idée du problème?
D'avance merci de votre aide.

thenif

PS: petite info j'avais déjà réussi a installer unbuntu 9.01 a partir d'un CD distribué dans un magazine j'ai voulu faire la mise à niveau via internet mais elle à du s'interrompre car linux ne démarre plus et j'ai des error fatal c'est pour ça que j'ai graver la dernières version d'unbutu pour l'installer directement s'en passer par des mises à niveau.
Donc mon ordi n'a plus de système d'exploitation fonctionnel.


3 réponses

Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 191
C'est une erreur classique et un problème bien connu. Certaines solutions sont données ici :
https://askubuntu.com/questions/117744/how-can-i-install-on-a-non-pae-cpu-error-kernel-requires-features-not-present

Tu peux aussi installer une autre distribution, par exemple une debian i386 jessie (ubuntu étant basé sur debian, tu devrais t'en sortir).

Bonne chance
Messages postés
3
Date d'inscription
dimanche 25 janvier 2015
Statut
Membre
Dernière intervention
26 janvier 2015

Merci de ta réponse!
J'ai effectivement essayé d'installer les versions 12.04, 13.04, 14.04 en i386 : toujours la même erreur.
Finalement il à fallu que je télécharge la version 9.01 pour pouvoir installer unbuntu sur mon ordi et de faire des mise à niveau.
Donc mise à niveau vers la version 10.04 effectué!
mise à niveau vers la version 12.04 en cours.
Et oui me faut entre 3 et 4 heures pour faire une mise à niveau!
pour la petite parenthèse : dire que beaucoup critique Microsoft pour le temps qu'il faut pour installer Windows!
Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 191
Je pense que ce n'est pas comparable (pour comparer le "temps" il faudrait pour ainsi dire comparer 3 réinstallations de windows, car une migration engendre une mise à jour de la grande majorité des paquets).

À titre indicatif j'ai installé une debian hier soir en 1h sur un PC neuf (30min de téléchargement, c'était une netinstall, 30min pour configurer les raccourcis, les favoris, extensions, thèmes etc).

Il faut garder à l'esprit que dans ton cas ton installation s'est avérée fastidieuse car tu as choisi un chemin bien compliqué. Comme je te l'ai dit :
1) tu peux installer une autre distribution, car cette limitation est spécifique à ubuntu (et ne concerne que certains PC, a priori plutôt anciens)
2) si tu veux installer une ubuntu et éviter ces migrations, tu peux installer directement la bonne via une netinstall, puisque cette approche (la 3e du lien précédent) semble permettre de contourner le problème. Autre avantage d'une netinstall : tout est à jour à la fin de l'installation.

Bonne continuation :-)
salut,
je pense que le version du système que tu essaie d'installer sur ta machine n'est pas compatible avec celle-ci. puisqu'il s'agit d'une erreur au niveau du processeur, cela veut dire que l'architecture du système n'est pas compatible avec celle de ton processeur. chaque système est conçu en fonction de l'architecture des processeurs.ainsi tu auras pour le même système d'exploitation une version pour les processeur intel comme les i386,i686; les processeurs AMD et autres. un système d'exploitation i386 par exemple fonctionne uniquement que sur le processeur intel et non les processeurs AMD et autres.
vérifie d'abord le fabricant de ton processeur (intel,amd,cyrix,...); ensuite son type c'est-à-dire si c'est un x86(32 bits) ou un x64 (64 bits) et enfin l'architecture du système que tu veux installer (i3XX,AMD 3XX). par exemple, si ton processeur est un intel x86, alors tu dois installer un système i386 x86. si c'est un intel x64, alors ce sera un système i386 x64 que tu dois choisir.
bonne chance à toi.
Messages postés
30193
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
15 octobre 2021
7 191
@Oberte :

le problème est que ubuntu pré-suppose (à tort) que les PC i386 supportent tous l'option pae, qui n'est pas supportée par les vieux micro processeurs (voir message 5 de jns55). Ça ne concerne encore que quelques rares PC mais thenif semble en faire partie. Il a donc pris la "bonne" version d'ubuntu (i386).

C'est simplement que les ubuntus i386 récentent (depuis ubuntu 12.04 en gros) ne peuvent plus s'installer sur les très vieux PC, à moins d'utiliser l'un des "workaround" mentionné dans mon dans le lien de mon premier message :
https://askubuntu.com/questions/117744/how-can-i-install-on-a-non-pae-cpu-error-kernel-requires-features-not-present

Le plus simple est donc comme je l'ai dit (et comme jns55 le rappelle) soit d'installer une autre distribution, soit d'installer ubuntu via une netinstall.
Bonjour,
Ton pc a un processeur ancien qui ne gère pas PAE voir ici pour savoir à quoi ça sert :
http://fr.wikipedia.org/wiki/Extension_d'adresse_physique

Il faut que tu installes une distribution linux avec un noyau non-pae. Ces distributions commencent à se faire rares car ce type de processeur est en voie de disparition du parc informatique. Voici quelques distributions qui ont une version non-pae
Xubuntu 12.04 (mais pas Ubuntu 12.04)
Bodhi linux (choisir la version non-pae)
Crunchbang linux (choisir la version pour pc anciens)
Antix Linux
Debian
Et toutes les autres distros pour i386...

Inutile d'essayer d'installer une version récente d'ubuntu ou de ses dérivées, le noyau non-pae a été abandonné.
Messages postés
3
Date d'inscription
dimanche 25 janvier 2015
Statut
Membre
Dernière intervention
26 janvier 2015

Merci à tous de vos réponses.

Autre info mon pc est un ibm Thinkpad avec un processeur pentium M de 1.7ghz.

Donc en passant par l'installation de ubuntu 9.01 j'ai donc ensuite mis à niveau jusqu'à la version 12.04 qui fonctionne sans problème et même mieux que la 9.01 qui me faisait un petit souci au niveau de l'affichage mais là c'est bon.

Je met en résolu.