Recherchev pour afficher données de plusieurs colonnes qui se suivent

[Fermé]
Signaler
Messages postés
158
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
25 mars 2021
-
Messages postés
10373
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 septembre 2021
-
Bonjour,

Je voudrais une petite aide.
Dans une feuille je dispose de 5 colonnes que je vais appeler A B C D et E, dans une autre feuille 3 colonnes appelées aa bb et cc (aa comportant les mêmes données que celles figurant en colonne A de ma 1ère feuille).
Je voudrais sur ma 2ème feuille (en colonne 4)créer une formule de Recherchev pour faire en sorte que si la donnée en aa2 est connue dans la feuille 1 en A que les données de la mêmes lignes en BCD et E soit rapatriés en dd ee ff gg et hh.
Ceci m éviterait de créer une formule de Recherchev pour chacune des colonnes.

Y a t il une solution.

Merci beaucoup

A voir également:

2 réponses

Messages postés
10373
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 septembre 2021
1 197
Bonjour,
Formule à placer en feuille 2 cellule [D2] pour récupérer la valeur en colonne [B] feuille 1.
=RECHERCHEV($A2;Feuil1!$A:$D;2;FAUX) 
Pour [C] en [E2]
=RECHERCHEV($A2;Feuil1!$A:$D;3;FAUX)

A répéter pour valeur [D et E]
Tirer le tous vers le bas

Messages postés
158
Date d'inscription
lundi 29 décembre 2014
Statut
Membre
Dernière intervention
25 mars 2021

Merci pour votre reponse mais n est il pas possible de tout rapatrier en 1 formule ?

Merci encore
Messages postés
10373
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
16 septembre 2021
1 197
Bonjour,
Vous avez les valeurs de 4 cellules à trouver dans les colonnes [B ; C ; D ; E] donc minimum 4 formules pour une ligne et ainsi de suite pour chaque ligne supplémentaire.