Qui peut m'aider à trouver la bonne formule? [Résolu/Fermé]

Signaler
Messages postés
41
Date d'inscription
mardi 27 novembre 2012
Statut
Membre
Dernière intervention
27 décembre 2016
-
Messages postés
41
Date d'inscription
mardi 27 novembre 2012
Statut
Membre
Dernière intervention
27 décembre 2016
-
Bonjour,

Ma question est dans le titre ;-)

en bref : j'ai une colonne A avec des montants compris entre 0 et 10000 €

dans ma colonne B --> si A est compris entre 0 et 249,99 B = 0
si A est compris entre 250 et 499,99 B = 25
si A est supérieur à 500 B = 50

dans ma colonne C --> si A est compris entre 0 et 250 C = 82,5
si A est compris entre 250 et 750 C = 137,5
si A est compris entre 750 et 2500 C = 220 (si je pouvais déjà avoir jusqu'ici ça serait top, mais si on sait en ajouter 2 de plus...)
si A est compris entre 2500 et 5000 C = 412,5
si A est compris entre 5000 et 10000 C = 550

j'arrive à faire un premier "si" mais je n'arrive pas à en faire plusieurs...

est-ce que c'est possible?

j'ai du voir ça à l'école il y a trèèèès longtemps mais je ne m'en rappelle plus...

un grand merci



3 réponses

Messages postés
25769
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2021
5 740
Bonjour
je viens de diffuser sur un autre post un modèle qui pourra peut être répondre à votre question, sans formule SI avec un tableau des correspondances que vous cherchez.
Regardez si ça peut vous aider et revenez si besoin pour adaptation
https://www.cjoint.com/c/EAtoRAiuJFK

sinon à défaut pour empiler des SI, toujours en partant du plus petits vers le plus grand et en éliminant si cellule vider:

=SI(A1="";"";SI(A1<250;0;SI(A1<500;25;SI(A1<750;137,5 .... ect....))))))
et fermer par autant de parenthèses qu'il y a de SI dans la formule.

crdlmnt


Messages postés
30715
Date d'inscription
mercredi 2 mai 2007
Statut
Modérateur
Dernière intervention
27 janvier 2021
7 268
Bonjour,

il faut imbriquer les SI :
=SI(A1<249,99;0;SI(A1<499,99;25;50)) 


cdlt
Messages postés
41
Date d'inscription
mardi 27 novembre 2012
Statut
Membre
Dernière intervention
27 décembre 2016
3
super, un grand merci à vous 2, ça marche et j'ai compris surtout ;-)
voila qqch qui va me faciliter la vie au boulot