Ne pas compter les cases "vides" [Fermé]

Signaler
-
Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020
-
Bonjour,

Je travaille actuellement sur un fichier Excel qui récupère les informations d'une base de donnée. J'utilise alors des fonctions pour résumer le contenu de la base.
J'utilise notamment la fonction BDNBVAL(Base;"Champ";plage_critères) pour compter un nombre d'équipement. Je me suis dit: "Cool, BDNBVAL ne compte que les cellules non vides, je vais donc pouvoir affiner mon comptage" MAIS... Les cases de ma bases qui sont "vides" ne le sont pas en réalité car elles sont le résultat d'une formule de récupération dans la base. J'ai donc des Cases à l'apparence vide, mais qui sont en fait des formules. BDNBVAL me les prend donc toujours en compte...
Comment procéder pour que mon résultat soit le nombre d'équipement sans compter les cases vides ?

En vous remerciant tous d'avance pour l'aide précieuse que vous apportez aux inexpérimentés comme moi :)

Jak

2 réponses

Messages postés
17227
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
16 septembre 2020
4 237
Bonsoir,

une cellule contenant une formule qui retourne rien "" n'est pas considérée comme vide puisqu'elle contient une formule
essaye comme cela pour la plage A2:A20 ç adapter bien sur

=SOMMEPROD((A2:A20<>"")*1)

tu peux également utiliser cette formule mais il faut impérativement que la totalité de ta plage contienne une formule
=NBVAL(A2:A20)-NB.VIDE(A2:A20)

par contre si ta formule renvoie des valeurs numérique tu peux utiliser cette formule
=NB(A2:A20) ou =NB.SI(A2:A20;">0")

une variante amusante pour compter uniquement les valeurs texte
=NB.SI(A2:A20;"?*")

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60551 internautes nous ont dit merci ce mois-ci

Messages postés
2364
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
31 août 2020
873
Bonjour,
Quand j'ai lu variante amusante j'ai bien sûr voulu voir!
=NB.SI(champ;"?*") compte uniquement les cellules qui contiennent du texte ou celles avec formule qui renvoient une valeur texte même si ce texte est vide ""
Alors que:
=NB.SI(champ;"><") compte uniquement les cellules qui contiennent du texte ou celles avec formule qui renvoient une valeur texte sauf si ce texte est vide "" ou commence par une espace Car(32) ou Car(160).
Messages postés
16502
Date d'inscription
mardi 12 juin 2007
Statut
Contributeur
Dernière intervention
17 septembre 2020
9 719
Bonjour,

Est ce que le contenu de tes cellules vides mais pas vides :) peut être assimilé à une valeur 0 ? Probablemenent.
Donc, tu peux prolonger ta zone de critère en ajoutant une celllule avec son nom et qui contiendrait <>0.

Cela étant, je n'ai pas compris quels sont tes critères ou si tu veux juste compter le nombres de cellules non vides.

m@rina