Faire une somme et la rediriger vers la feuille 2

Fermé
Addik04 - 25 nov. 2014 à 23:05
jordane45 Messages postés 36583 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 29 novembre 2022 - 2 déc. 2014 à 09:45
Bonjour, je suis un débutant dans la matière. Je veux faire une moyenne d'une série de 60 chiffres (de b1@b60) qui se trouve à la feuille 1, puis présenter le résultat de la moyenne à la feuille 2.

Cependant, je ne peux pas faire ceci avec les formules excel, je dois faire la somme et la diviser par le nombre de chiffre qu'il y a (60).

J'attends votre aide, merci

Will


A voir également:

2 réponses

michel_m Messages postés 16582 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 27 novembre 2022 3 284
26 nov. 2014 à 08:01
Bonjour,

en VBA ?

Pourtant, cela ne pose aucun problème avec des formules....

?
0
C'est pour un travail. Je ne peux pas prendre la formule de la moyenne par exemple. Je dois la faire à la main, donc la somme et cette somme par le nombre de chiffre (60 dans mon cas)
0
PlacageGranby Messages postés 393 Date d'inscription mercredi 26 mars 2014 Statut Membre Dernière intervention 7 mars 2019 26
Modifié par PlacageGranby le 1/12/2014 à 21:22
Bonjour

La somme divisé par le nombre de chiffre sans utiliser la formule de la moyenne...

=SOMME(Feuil1!B1:B60)/NBVAL(Feuil1!B1:B60)

Tu mentionnes
C'est pour un travail.
Mais encore....
Est-ce que tu as spécifiquement besoin de le faire via programmation VBA ?
0
michel_m Messages postés 16582 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 27 novembre 2022 3 284 > PlacageGranby Messages postés 393 Date d'inscription mercredi 26 mars 2014 Statut Membre Dernière intervention 7 mars 2019
2 déc. 2014 à 07:26
Merci de répéter ce que j'ai écris...
0
jordane45 Messages postés 36583 Date d'inscription mercredi 22 octobre 2003 Statut Modérateur Dernière intervention 29 novembre 2022 4 411
2 déc. 2014 à 09:45
Bonjour,

Pour le calcul ..Il te suffit d'utiliser une boucle...
Sub somplage()
Dim nb As Long
Dim somme As Double
Dim Rng As Range
Set Rng = Range("A1:A60")

somme = 0
nb = 0
For Each cell In Rng
if cell.value <> "" then
  somme = somme + cell.Value
  nb = nb + 1
end if
Next

Moyenne = somme / nb

MsgBox Moyenne

End Sub



Après.. pour l'afficher sur la feuille 2 .. je te laisse faire.
Je pense que tu vas savoir.

Si c'est pour un exercice... tu dois avoir un minimum de connaissances....
sinon pourquoi t'avoir donner ça à faire...


0