Formule si case vide

Résolu/Fermé
YM88000
Messages postés
5
Date d'inscription
samedi 25 octobre 2014
Statut
Membre
Dernière intervention
13 juillet 2015
- 25 oct. 2014 à 19:10
YM88000
Messages postés
5
Date d'inscription
samedi 25 octobre 2014
Statut
Membre
Dernière intervention
13 juillet 2015
- 26 oct. 2014 à 16:19
Bonjour les experts.


Merci par avance de votre aide.

Je cherche à éviter qu'un calcul ne se fasse dans une cellule qui fait référence à 2 autres cellules vides.
J'ai essayé la formule suivante =si(estvide(S2);"";S2/P2)
Mais le résultat est un #valeur qui du coup m'empêche de compiler la colonne donc l'exploitation de mon tableau.

Merci beaucoup.

Yves

3 réponses

ThauTheme
Messages postés
1442
Date d'inscription
mardi 21 octobre 2014
Statut
Membre
Dernière intervention
29 juillet 2022
158
25 oct. 2014 à 19:40
Bonsoir Yves, bonsoir le forum,

peut-être comme ça :
=SI(OU(S2="";P2="");"";S2/P2) 


3
YM88000
Messages postés
5
Date d'inscription
samedi 25 octobre 2014
Statut
Membre
Dernière intervention
13 juillet 2015

26 oct. 2014 à 16:19
Bonjour,
C'est la bonne formule. Merci Thautheme.
Et merci aux autres également.

bonne journée.
0
thivame
Messages postés
60
Date d'inscription
vendredi 9 avril 2004
Statut
Membre
Dernière intervention
4 octobre 2021
4
26 oct. 2014 à 08:43
bonjour,
voir avec le format de cellule aussi??
cordialement
0
Raymond PENTIER
Messages postés
56508
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
18 août 2022
17 202
26 oct. 2014 à 02:58
Bonjour YM88000.

Je ne comprends pas ta question : j'ai reproduit ta formule en U2 et j'ai essayé diverses combinaisons, et je ne trouve jamais ton affichage "#valeur"
   P2=3 S2=6   -> U2=2
P2=3 S2=6 -> U2=2
P2=3 S2=0 -> U2=0
P2=3 S2="" -> U2=""
P2=6 S2=3 -> U2=0,5
P2=0 S2=3 -> U2=#DIV/0!
P2="" S2=3 -> U2=#DIV/0!
P2="" S2="" -> U2=""
Dis-nous quel résultat tu voudrais voir s'afficher pour chacune de ces 8 combinaisons.

Dans le cas général, c'est le dénominateur nul (ou vide) qu'il faut gérer, avec la formule =SI(OU(P2=0;P2="");"";S2/P2)
Mais ni ThauTheme ni moi ne savons ce que tu veux faire avec ton fichier ...
-1
Mytå
Messages postés
2967
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
916
Modifié par Mytå le 26/10/2014 à 02:34
Salut le Forum

Pour obtenir #VALEUR!, il faut qu'une cellule contient soit du texte
ou une formule retournant du texte dans le style =SI(A1="";"";A1)

Si tu testes = ESTVIDE(S2) et que S2 contient une formule retournant ""
tu obtiens FAUX car S2 contient du texte. Alors P2/S2 donne #VALEUR!

Mytå
0