[Java] Problème d'installation d'Eclipse [Résolu/Fermé]

Signaler
-
 Anomyme -
Bonjour à tous !

Voilà je vous écris car je souhaite me mettre au Java. J'ai donc téléchargé et installé le dernier JDK, puis téléchargé Eclipse.
J'ai paramétré la variable d'environnement PATH puis j'ai souhaité lancer eclipse.exe. Il m'a alors affiché un message me disant "A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available in order to run Eclipse. No Java Virtual Machine was found after searching the following locations ............"

Bref, après quelques recherches, j'ai lu qu'il fallait paramétrer aussi les variables d'environnement CLASSPATH et JAVA_HOME mais ça n'a rien changé.
Par contre, lorsque je lance eclipse à partir d'une ligne de commande, en utilisant -vm, ça marche !? Mais le problème, c'est que je suis obligé de taper cette ligne de commande à chaque fois que je veux lancer eclipse, ce qui est assez dérangeant à la longue. Et si jamais je veux passer par un double-clic sur le raccourci, le message d'erreur réapparait.

Donc j'aurai souhaité votre aide pour savoir comment faire pour résoudre ce problème.
Ah oui aussi, petite précision : lorsque je tape java -version en ligne de commande, il me dit que 'java' n'est pas une commande reconnue :( Est-ce que ça voudrait dire que mon JDK n'est vraiment pas installé ?

Merci d'avance pour vos réponses !

11 réponses

Bonjour ,
malgré que sa date un peu mais moi aussi j'ai réussi a reglé le probléme en

copiant le dossier jre depuis c:..\java\jdk1.6
et en le mettant dans le dossier c:..\eclipse\

sa marche aussi si on copie juste le dossier bin de mais cette fois en le mettant dans c:..\eclipse\jre\ si le dossier jre n'existe pas crée le

J'esper que sa va vous aider :)
49
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 61458 internautes nous ont dit merci ce mois-ci

ca marche pas pour meme si j'ai fait ce que vous dites, ou est-il le probleme et merci d'avance ;)
vous m'avez sauvé la vie! lol merci bcp :)
merci beaucoup; j'ai procédé comme vous avez dit ça marché
ça marche à verveille j'ai en plus modifier le chemin dans eclipse.ini et remplacer le "c:\programs files\" par ".\"
Merci infiniment
Messages postés
814
Date d'inscription
jeudi 19 juillet 2007
Statut
Membre
Dernière intervention
17 avril 2020
113
Bonjour,
Si le message d'erreur "java n'est pas reconnu en tant que commande.." apparait, cela veut dire que vous n'avez pas bien aprametré la variable PATH.
Pour verifier que java est bien installé: verifiez (si vous ne l'avez pas changé pendant l'installation) le repertoire c:\program files\java\jdk(numéro de version)\bin\, vous devez trouvé un ensemble de fichiers executables: java.exe, javaw.exe, jar.exe autrement vous devz reinstaller le jdk.
Si vous pouvez lancer eclipse par l'option -vm, il vous suffit de l'ajouter à votre raccourci: ouvrez ses propriétés (clique droit et voire la fin de liste), et ajoutez -vm à la fin de la cible.
Si ça ne marche pas: mettez tous les messages d'erreurs dans toutes les étapes.
Bon Java
J'ai trouvé un fichier eclipse.ini dans lequel se trouve des lignes de configuration comme celles-ci :


-startup
plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
-vmargs "C:\Program Files (x86)\Java\jre6\bin"
-Xms40m
-Xmx256m

J'ai rajouté le chemin de ma machine virtuelle derrière -vmargs, ça a suffi
Mercii ça marche !
je trouve le repertoire c:\program files\java\jdk(numéro de version)\bin\, vous devez trouvé un ensemble de fichiers executables: java.exe, javaw.exe, jar.exe mais l eclipse ne travail pas que ce que je devrais faire c urgent
Pour ma part le problème(avec le meme message d'erreur) vennait du fait que j'utilisé la version 64bits de eclipse avec un java 32bits. J'ai du naviguer avec explorer 64bits et là le site de JAVA propose directement le lien en 64bits maintenant c'est impeccable. (difficile de trouver rapidement java 64bits sinon https://www.java.com/fr/download/faq/java_win64bit.xml
Merci beaucoup, pour moi, c'était la solution (repasser à un eclipse en 32bits pour ne plus avoir de problèmes)
Bonjour,

Pourquoi ne pas suivre un tutoriel Eclipse : https://java.developpez.com/cours/#eclipse
Ou alors regarder la soluce dans la F.A.Q Eclipse : https://java.developpez.com/faq/eclipse/
Parce que ça ne dit pas grand chose de plus sur les problèmes rencontrés avec différentes OS. Avec 7 je suis d'un bout à l'autre à la majuscule près mais rien n'y fait ça ne marche pas..
Bonjour le problème ce qu'il faut installer la version 64bit de java http://www.java.com/fr/download/manual.jsp.
Puis dans le dossier d'installation « eclipse » il faut supprimer le dossier « jre » si vous avez le rajouté manuellement, je viens de réglé mon problème avec cette astuce.
Système d'exploitation : win 7 64 bit
Messages postés
1
Date d'inscription
lundi 15 avril 2013
Statut
Membre
Dernière intervention
15 avril 2013

J'ai installer la version 64 bits et j'ai ce message qui apparaît:

Failed to load the JNI shared library
"c:\Users\.......eclipse\jre\bin\client\jvm.d"

Merci d'avance
merci ca a marché pour moi! ;)
C'était bien la version 64 bits qui posait problème.

Merci encore.
Personne pour me donner un petit coup de main ? snif
Messages postés
8
Date d'inscription
vendredi 2 novembre 2007
Statut
Membre
Dernière intervention
24 décembre 2007

bonjour j'ai le meme probleme mais moi j'arrive pas a la lancer par commande pourriez me dire comment tapez ta commande pour ça marche merci d'avance
Je crois que pour ne pas avoir des problèmes faudrait :
avoir la JDK/JRE et Eclipse pour un même nombre de bits( JDK/JRE et Eclipse 32bits ou x86. ou alors JDK/JRE et Eclipse 64Bits ou x64),
Après le téléchargement, Pour lancer Eclipse directement après l'installation sans plus rien faire, assurez vous, si vous avez un 64 bits, que vous installez bien dans "Program Files" et non "Program Files (x86)"
bonsoir tout le monde :)

j'ai exactement le même problème, j'ai essayer toutes les astuces qui ont été données sur ce topic mais pourtant j'ai le meme message d'erreur quand j'essaye de lancer eclipse :(

quelqu'un n'aurait pas un autre conseil ?

merci d'avance
Merci Chakib ;)